lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 31 May 2011 15:41:16 +0800
From:	Greg KH <greg@...ah.com>
To:	Xiangliang Yu <yuxiangl@...vell.com>
Cc:	"James.Bottomley@...e.de" <James.Bottomley@...e.de>,
	"jslaby@...e.cz" <jslaby@...e.cz>,
	"linux-scsi@...r.kernel.org" <linux-scsi@...r.kernel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Jacky Feng <jfeng@...vell.com>
Subject: Re: [PATCH 3/9] [SCSI] mvsas: Add driver version and interrupt
 coalescing to device 	attributes in sysfs

On Tue, May 31, 2011 at 12:26:45AM -0700, Xiangliang Yu wrote:
> 
> >Then I would strongly recommend never exporting this value to allow it
> >to be changed at all then.  It doesn't sound worth it.
> OK, Thanks!
> I remove the sysfs file and the modified patch is:

Thanks for removing it, but you still left part of it in the patch, see
below.

> diff --git a/drivers/scsi/mvsas/mv_init.c b/drivers/scsi/mvsas/mv_init.c
> index 9f1cccc..d977684 100644
> --- a/drivers/scsi/mvsas/mv_init.c
> +++ b/drivers/scsi/mvsas/mv_init.c
> @@ -34,6 +34,8 @@ MODULE_PARM_DESC(collector, "\n"
>  	"\tThe mvsas SAS LLDD supports both modes.\n"
>  	"\tDefault: 1 (Direct Mode).\n");
>  
> +int interrupt_coalescing = 0x80;

This should be named something else, or made static, as you just made it
a global name, which is not good at all.

> @@ -48,6 +50,8 @@ static const struct mvs_chip_info mvs_chips[] = {
>  	[chip_1320] =	{ 2, 4, 0x800, 17, 64,  9, &mvs_94xx_dispatch, },
>  };
>  
> +struct device_attribute *mvst_host_attrs[] = { NULL };
> +
>  #define SOC_SAS_NUM 2
>  #define SG_MX 64
>  
> @@ -74,6 +78,7 @@ static struct scsi_host_template mvs_sht = {
>  	.slave_alloc		= mvs_slave_alloc,
>  	.target_destroy		= sas_target_destroy,
>  	.ioctl			= sas_ioctl,
> +	.shost_attrs		= mvst_host_attrs,

Here, you don't need these at all now, right?

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ