[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8523.1310213890@jrobl>
Date: Sat, 09 Jul 2011 21:18:10 +0900
From: "J. R. Okajima" <hooanon05@...oo.co.jp>
To: Miklos Szeredi <miklos@...redi.hu>
Cc: Erez Zadok <ezk@....cs.sunysb.edu>,
Andrew Morton <akpm@...ux-foundation.org>,
"viro\@ZenIV.linux.org.uk Viro" <viro@...IV.linux.org.uk>,
Linus Torvalds <torvalds@...ux-foundation.org>,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
apw@...onical.com, nbd@...nwrt.org, neilb@...e.de,
hramrach@...trum.cz, jordipujolp@...il.com
Subject: Re: [PATCH 0/7] overlay filesystem: request for inclusion
Miklos Szeredi:
> Here's a patch to limit stacking overlayfs instances on top of each
> other and on ecryptfs to prevent kernel stack overflow.
I don't think it a good idea to introduce such new member to generic
struct super_block.
- the new member is unrelated to most of other fs.
- ecryptfs already rejects such nests by checking
(sb->s_type == &ecryptfs_fs_type).
Instead I'd suggest you to introduce a new small test function,
something like
int test_nested(sb)
{
return sb->s_magic == ECRYPTFS_SUPER_MAGIC
|| sb->s_type == &ovl_fs_type;
}
Of course "#ifdef CONFIG_ECRYPT_FS" or something should be added too.
If overlayfs had its own SUPER_MAGIC number, it might be better to test it
instead of s_type. But there is no such magic number currently, and I am
afraid intoducing it may affect stat/statfs for overlayfs which you
might dislike.
J. R. Okajima
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists