[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <s5hzkk2y6je.wl%tiwai@suse.de>
Date: Mon, 25 Jul 2011 12:54:29 +0200
From: Takashi Iwai <tiwai@...e.de>
To: Lionel Debroux <lionel_debroux@...oo.fr>
Cc: Jaroslav Kysela <perex@...ex.cz>, alsa-devel@...a-project.org,
linux-kernel@...r.kernel.org, Kees Cook <kees.cook@...onical.com>,
Emese Revfy <re.emese@...il.com>,
kernel-janitors@...r.kernel.org
Subject: Re: ac97: quiet make W=1 noise by initializing all fields of snd_ac97_codec_id_vendors and snd_ac97_codec_ids.
At Sun, 24 Jul 2011 11:40:56 +0200,
Lionel Debroux wrote:
>
> make W=1 bitterly complains about missing initializations in
> snd_ac97_codec_id_vendors and snd_ac97_codec_ids.
> Initialize the last field, to make the output of make W=1 more readable.
>
> Patch against current Linus tree.
If we change the whole table entries, it'd be better to use C99 style
init, e.g.
#define _CODEC(_id, _mask, _name) \
.id = _id, .mask = _mask, .name = _name
static const struct ac97_codec_id snd_ac97_codec_id_vendors[] = {
{ _CODEC(0x41445300, 0xffffff00, "Analog Devices"),},
...
static const struct ac97_codec_id snd_ac97_codec_ids[] = {
{ _CODEC(0x41445303, 0xffffffff, "AD1819"), .patch = patch_ad1819 },
...
{ _CODEC(0x53494c20, 0xffffffe0, "Si3036,8"), .patch = mpatch_si3036, \
.mpatch = mpatch_si3036, .flags = AC97_MODEM_PATCH },
...
thanks,
Takashi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists