[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110726093624.2d067e1b@jbarnes-desktop>
Date: Tue, 26 Jul 2011 09:36:24 -0700
From: Jesse Barnes <jbarnes@...tuousgeek.org>
To: Keith Packard <keithp@...thp.com>
Cc: Dave Airlie <airlied@...hat.com>, intel-gfx@...ts.freedesktop.org,
linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH 1/5] drm/i915: Use dp_detect_common in
hotplug helper function
On Mon, 25 Jul 2011 23:36:30 -0700
Keith Packard <keithp@...thp.com> wrote:
> This uses the common dpcd reading routine, i915_dp_detect_common,
> instead of open-coding a call to intel_dp_aux_native_read. Besides
> reducing duplicated code, this also gains the read retries which
> may be necessary when a cable is first plugged back in and the link
> needs to be retrained.
>
> Signed-off-by: Keith Packard <keithp@...thp.com>
> ---
> drivers/gpu/drm/i915/intel_dp.c | 39 +++++++++++++++++++--------------------
> 1 files changed, 19 insertions(+), 20 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
> index dcc7ae6..45db810 100644
> --- a/drivers/gpu/drm/i915/intel_dp.c
> +++ b/drivers/gpu/drm/i915/intel_dp.c
> @@ -1567,6 +1567,20 @@ intel_dp_link_down(struct intel_dp *intel_dp)
> POSTING_READ(intel_dp->output_reg);
> }
>
> +static enum drm_connector_status
> +i915_dp_detect_common(struct intel_dp *intel_dp)
Maybe you can fix the prefix of this function while you're at it since
it's not i915 or even i9xx specific?
--
Jesse Barnes, Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists