[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1312880109.1743.26.camel@ymzhang>
Date: Tue, 09 Aug 2011 16:55:09 +0800
From: Yanmin Zhang <yanmin_zhang@...ux.intel.com>
To: Dave Young <hidave.darkstar@...il.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [PATCH ] printk: add module parameter console_suspend to
control console_suspend_enabled
On Tue, 2011-08-09 at 16:01 +0800, Dave Young wrote:
> On Tue, Aug 9, 2011 at 11:09 AM, Yanmin Zhang
> <yanmin_zhang@...ux.intel.com> wrote:
> > We are enabling some power features on medfield. To test suspend-2-RAM
> > conveniently, we need turn on/off console_suspend_enabled frequently.
> >
> > Below patch adds a module parameter, so users could change it by:
> > /sys/module/printk/parameters/console_suspend_enabled
>
> What about change name to no_console_suspend? Or it will be weird if
> boot kernel with both no_console_suspend and
> printk.console_suspend_enabled set.
Thanks for the comments. How about changing the name to console_suspend?
If changing it to no_console_suspend, we can't map the input to console_suspend_enabled
directly.
Below is the new patch.
---
We are enabling some power features on medfield. To test suspend-2-RAM
conveniently, we need turn on/off console_suspend_enabled frequently.
Below patch adds a module parameter, so users could change it by:
/sys/module/printk/parameters/console_suspend
Signed-off-by: Yanmin Zhang <yanmin_zhang@...ux.intel.com>
---
kernel/printk.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/kernel/printk.c b/kernel/printk.c
index 37dff34..1decef6 100644
--- a/kernel/printk.c
+++ b/kernel/printk.c
@@ -1106,6 +1106,8 @@ static int __init console_suspend_disable(char *str)
return 1;
}
__setup("no_console_suspend", console_suspend_disable);
+module_param_named(console_suspend, console_suspend_enabled,
+ bool, S_IRUGO | S_IWUSR);
/**
* suspend_console - suspend the console subsystem
--
1.7.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists