lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 11 Aug 2011 10:23:37 +0200
From:	Jens Axboe <jaxboe@...ionio.com>
To:	Shaohua Li <shli@...nel.org>
CC:	Kyungmin Park <kmpark@...radead.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"arnd@...db.de" <arnd@...db.de>,
	"jh80.chung@...sung.com" <jh80.chung@...sung.com>,
	"linux-mmc@...r.kernel.org" <linux-mmc@...r.kernel.org>
Subject: Re: [RFC PATCH v2] Add new elevator ops for request hint

On 2011-08-11 03:14, Shaohua Li wrote:
> 2011/8/11 Shaohua Li <shli@...nel.org>:
>> 2011/8/11 Kyungmin Park <kmpark@...radead.org>:
>>> Hi Jens
>>>
>>> Now eMMC device requires the upper layer information to improve the data
>>> performance and reliability.
>>>
>>> . Context ID
>>> Using the context information, it can sort out the data internally and improve the performance.
>>> The main problem is that it's needed to define "What's the context".
>>> Actually I expect cfq queue has own unique ID but it doesn't so decide to use the pid instead
>>>
>>> . Data Tag
>>> Using the Data Tag (1-bit information), It writes the data at SLC area when it's hot data. So it can make the chip more reliable.
>>> First I expect the REQ_META but current ext4 doesn't pass the WRITE_META. only use the READ_META. so it needs to investigate it.
>>>
>>> With these characteristics, it's helpful to teach the device. After some consideration. it's needed to pass out these information at request data structure.
>>>
>>> Sample usage is following in drivers/mmc/card/block.c
>>>
>>>        struct elevator_queue *e = md->queue.queue->elevator;
>>>        struct request_hint hint;
>>>        int ret;
>>>
>>>        if (e->ops->elevator_get_req_hint_fn && req)
>>>                ret = e->ops->elevator_get_req_hint_fn(req, &hint);
>> please put this to blkdev.h or similar. directly using it here
>> is abnormal.
> BTW, we can add a (rq->cmd_flags & REQ_ELVPRIV) check here to make
> sure the request is at io scheduler.

Yep, that should all go inside elv_get_request_context() or whatever is
a good name. I don't want the hint structure, the caller can just check
the request flags himself.

So something like:

int elv_get_request_context(struct request_queue *q, struct request *rq)
{
        struct elevator_queue *e = q->elevator;

        if (!(rq->cmd_flags & REQ_ELVPRIV))
                return -1;

        if (e->ops->elevator_get_req_context_fn)
                return e->ops->elevator_get_req_context_fn(q, rq);

        return -1;
}

and then cfq/others adding that helper to provide the mapping.

Context is a bad name, but so is hint. Perhaps app_key would be better,
as it more direcly infers what is being returned.

-- 
Jens Axboe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ