[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1318575363.11016.8.camel@dagon.hellion.org.uk>
Date: Fri, 14 Oct 2011 07:56:02 +0100
From: Ian Campbell <Ian.Campbell@...rix.com>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: David Miller <davem@...emloft.net>,
"rientjes@...gle.com" <rientjes@...gle.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"hch@...radead.org" <hch@...radead.org>,
"jaxboe@...ionio.com" <jaxboe@...ionio.com>,
"linux-mm@...ck.org" <linux-mm@...ck.org>
Subject: Re: [PATCH] mm: add a "struct page_frag" type containing a page,
offset and length
On Thu, 2011-10-13 at 22:22 +0100, Andrew Morton wrote:
> Looks OK to me. I'm surprised we don't already have such a thing.
>
> Review comments:
>
>
> > +struct page_frag {
> > + struct page *page;
> > +#if (BITS_PER_LONG > 32) || (PAGE_SIZE >= 65536)
>
> It does add risk that people will add compile warnings and bugs by
> failing to consider or test the other case.
>
> We could reduce that risk by doing
>
> #if (PAGE_SIZE >= 65536)
>
> but then the 32-bit version would hardly ever be tested at all.
Indeed. The first variant has the benefit that most 32-bit arches will
test one case and most 64-bit ones the other.
Perhaps the need to keep this struct small is not so acute as it is for
the skb_frag_t I nicked it from and just using __u32 unconditionally is
sufficient?
>
> > + __u32 page_offset;
>
> I suggest this be called simply "offset".
ACK.
Thanks,
Ian.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists