[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <op.v3fpwyxc3l0zgt@mpn-glaptop>
Date: Sun, 16 Oct 2011 10:01:36 +0200
From: "Michal Nazarewicz" <mina86@...a86.com>
To: "Marek Szyprowski" <m.szyprowski@...sung.com>,
"Andrew Morton" <akpm@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linux-media@...r.kernel.org, linux-mm@...ck.org,
linaro-mm-sig@...ts.linaro.org,
"Kyungmin Park" <kyungmin.park@...sung.com>,
"Russell King" <linux@....linux.org.uk>,
"KAMEZAWA Hiroyuki" <kamezawa.hiroyu@...fujitsu.com>,
"Ankita Garg" <ankita@...ibm.com>,
"Daniel Walker" <dwalker@...eaurora.org>,
"Mel Gorman" <mel@....ul.ie>, "Arnd Bergmann" <arnd@...db.de>,
"Jesse Barker" <jesse.barker@...aro.org>,
"Jonathan Corbet" <corbet@....net>,
"Shariq Hasnain" <shariq.hasnain@...aro.org>,
"Chunsang Jeong" <chunsang.jeong@...aro.org>,
"Dave Hansen" <dave@...ux.vnet.ibm.com>
Subject: Re: [PATCH 2/9] mm: alloc_contig_freed_pages() added
On Sat, 15 Oct 2011 01:29:33 +0200, Andrew Morton <akpm@...ux-foundation.org> wrote:
> On Thu, 06 Oct 2011 15:54:42 +0200
> Marek Szyprowski <m.szyprowski@...sung.com> wrote:
>
>> From: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
>>
>> This commit introduces alloc_contig_freed_pages() function
>
> The "freed" seems redundant to me. Wouldn't "alloc_contig_pages" be a
> better name?
The “freed” is there because the function operates on pages that are in
buddy system, ie. it is given a range of PFNs that are to be removed
from buddy system.
There's also a alloc_contig_range() function (added by next patch)
which frees pages in given range and then calls
alloc_contig_free_pages() to allocate them.
IMO, if there was an alloc_contig_pages() function, it would have to
be one level up (ie. it would figure out where to allocate memory and
then call alloc_contig_range()). (That's really what CMA is doing).
Still, as I think of it now, maybe alloc_contig_free_range() would be
better?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists