lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <59D8A47D-7B28-48CA-82D3-BCB50619D683@iki.fi>
Date:	Sun, 6 Nov 2011 23:37:53 +0200
From:	Aaro Koskinen <aaro.koskinen@....fi>
To:	Peter Huewe <peterhuewe@....de>
Cc:	Greg Kroah-Hartman <gregkh@...e.de>,
	Arnaud Patard <apatard@...driva.com>,
	Dan Carpenter <dan.carpenter@...cle.com>,
	devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] staging/xgifb: Convert pci_table entries to PCI_DEVICE (if PCI_ANY_ID is used)

Hi,

On 6.11.2011, at 23.05, Peter Huewe wrote:
> This patch converts pci_table entries to use the PCI_DEVICE macro,
> if .subvendor and .subdevice are set to PCI_ANY_ID,
> and thus improves readability.
>
> KernelVersion: Staging-20111106
> ---
>  drivers/staging/xgifb/XGI_main.h |   12 ++++--------
>  1 files changed, 4 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/xgifb/XGI_main.h b/drivers/staging/ 
> xgifb/XGI_main.h
> index 71aebe3..0c3f421 100644
> --- a/drivers/staging/xgifb/XGI_main.h
> +++ b/drivers/staging/xgifb/XGI_main.h
> @@ -32,14 +32,10 @@
>  #endif
>
>  static DEFINE_PCI_DEVICE_TABLE(xgifb_pci_table) = {
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 0},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_27, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 1},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_40, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 2},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_42, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 3},
> +	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), 0, 0, 0},

I think the correct way would be

	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), .driver_data = 0},

or

	{PCI_VDEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), 0},

But I don't see the driver_data even being used anywhere, so then you  
could
just simply say:

	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20)},

A.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ