[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4EF0D556.3030701@gmail.com>
Date: Tue, 20 Dec 2011 12:35:02 -0600
From: Rob Herring <robherring2@...il.com>
To: Dong Aisheng <b29396@...escale.com>
CC: linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linus.walleij@...ricsson.com, s.hauer@...gutronix.de,
shawn.guo@...escale.com, kernel@...gutronix.de,
grant.likely@...retlab.ca, devicetree-discuss@...ts.ozlabs.org,
cjb@...top.org, w.sang@...gutronix.de
Subject: Re: [RFC PATCH v3 1/5] dt: add of_get_child_count helper function
On 12/20/2011 11:40 AM, Dong Aisheng wrote:
> From: Dong Aisheng <dong.aisheng@...aro.org>
>
> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.
>
> ---
> Changes v1->v2:
> * change the name from of_get_child_number to of_get_child_count
>
> Signed-off-by: Dong Aisheng <dong.aisheng@...aro.org>
> Cc: Grant Likely <grant.likely@...retlab.ca>
> Cc: Rob Herring <rob.herring@...xeda.com>
I assume you want this to go in with the rest of the series? If not, let
me know.
Acked-by: Rob Herring <rob.herring@...xeda.com>
Rob
> ---
> include/linux/of.h | 16 ++++++++++++++++
> 1 files changed, 16 insertions(+), 0 deletions(-)
>
> diff --git a/include/linux/of.h b/include/linux/of.h
> index 4948552..d0d91a1 100644
> --- a/include/linux/of.h
> +++ b/include/linux/of.h
> @@ -189,6 +189,17 @@ extern struct device_node *of_get_next_child(const struct device_node *node,
> for (child = of_get_next_child(parent, NULL); child != NULL; \
> child = of_get_next_child(parent, child))
>
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> + struct device_node *child = NULL;
> + int num = 0;
> +
> + while ((child = of_get_next_child(np, child)))
> + num++;
> +
> + return num;
> +}
> +
> extern struct device_node *of_find_node_with_property(
> struct device_node *from, const char *prop_name);
> #define for_each_node_with_property(dn, prop_name) \
> @@ -262,6 +273,11 @@ static inline bool of_have_populated_dt(void)
> #define for_each_child_of_node(parent, child) \
> while (0)
>
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> + return -ENOSYS;
> +}
> +
> static inline int of_device_is_compatible(const struct device_node *device,
> const char *name)
> {
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists