[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20120111230110.GE20968@S2101-09.ap.freescale.net>
Date: Thu, 12 Jan 2012 07:01:12 +0800
From: Shawn Guo <shawn.guo@...aro.org>
To: Stephen Warren <swarren@...dia.com>
Cc: Dong Aisheng-B29396 <B29396@...escale.com>,
Dong Aisheng <dongas86@...il.com>,
"linus.walleij@...ricsson.com" <linus.walleij@...ricsson.com>,
"s.hauer@...gutronix.de" <s.hauer@...gutronix.de>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"rob.herring@...xeda.com" <rob.herring@...xeda.com>,
"kernel@...gutronix.de" <kernel@...gutronix.de>,
"cjb@...top.org" <cjb@...top.org>,
"devicetree-discuss@...ts.ozlabs.org"
<devicetree-discuss@...ts.ozlabs.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>
Subject: Re: [RFC PATCH v3 2/5] pinctrl: add dt binding support for pinmux
mappings
On Wed, Jan 11, 2012 at 11:41:56AM -0800, Stephen Warren wrote:
> Shawn Guo wrote at Tuesday, January 10, 2012 6:05 AM:
> > On Tue, Jan 10, 2012 at 08:21:05AM +0000, Dong Aisheng-B29396 wrote:
> > > Here what I wonder is that do we need to allow the platform to use a func-name
> > > property in their pinmux func node or pinmux group node to specify the name.
> >
> > I do not see the necessity.
> >
> > > If it is allowed, then it could be flexible for soc to define their names.
> > > If not there may be limitations on their node names since we can only get it from
> > > the node name.
> >
> > To me, the node name is perfectly fine to be used for that purpose.
>
> I'd prefer if we could use integers over strings if at all possible, but
> that does have a dependency on dtc getting a syntax to define named
> constants, or the kernel pre-processing the .dts files before passing
> them to dtc.
>
> But if we have to use strings, I will point out that the pin names I
> chose for Tegra may not be suitable as DT node names; I don't /think/
> the DT node names can contain spaces, but I chose to name the Tegra
> pinctrl pins after both their pin name and GPIO name so that it's
> easier to correlate the two:
>
> PINCTRL_PIN(TEGRA_PIN_SDIO3_CLK_PA6, "SDIO3_CLK PA6"),
>
> Now, I could change that, but I'd prefer not to.
>
Hmm, we are talking about function name and pingroup name instead of
individual pin name. In your pinctrl-tegra20.c, they are .name and
.groups as below.
#define FUNCTION(fname) \
{ \
.name = #fname, \
.groups = fname##_groups, \
.ngroups = ARRAY_SIZE(fname##_groups), \
}
--
Regards,
Shawn
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists