[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20120120085644.60d14c17.kamezawa.hiroyu@jp.fujitsu.com>
Date: Fri, 20 Jan 2012 08:56:44 +0900
From: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
To: Michal Hocko <mhocko@...e.cz>
Cc: "linux-mm@...ck.org" <linux-mm@...ck.org>,
"hannes@...xchg.org" <hannes@...xchg.org>,
"akpm@...ux-foundation.org" <akpm@...ux-foundation.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Hugh Dickins <hughd@...gle.com>, Ying Han <yinghan@...gle.com>
Subject: Re: [PATCH] memcg: remove PCG_CACHE page_cgroup flag
On Thu, 19 Jan 2012 14:43:58 +0100
Michal Hocko <mhocko@...e.cz> wrote:
> On Thu 19-01-12 18:17:11, KAMEZAWA Hiroyuki wrote:
> > This patch is onto memcg-devel, can be applied to linux-next, too.
>
> Just for record memcg-devel tree should _always_ be compatible with
> linux-next. It just contains patches which are memcg related to be more
> stable for memcg specific development.
>
> >
> > ==
> > From 529653c266b0682894d64e4797fcaf6a3c35db25 Mon Sep 17 00:00:00 2001
> > From: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
> > Date: Thu, 19 Jan 2012 17:09:41 +0900
> > Subject: [PATCH] memcg: remove PCG_CACHE
> >
> > We record 'the page is cache' by PCG_CACHE bit to page_cgroup.
> > Here, "CACHE" means anonymous user pages (and SwapCache). This
> > doesn't include shmem.
>
> > Consdering callers, at charge/uncharge, the caller should know
> > what the page is and we don't need to record it by using 1bit
> > per page.
> >
> > This patch removes PCG_CACHE bit and make callers of
> > mem_cgroup_charge_statistics() to specify what the page is.
> >
> > Changelog since RFC.
> > - rebased onto memcg-devel
> > - rename 'file' to 'not_rss'
>
> The name is confusing.
>
> Other than that the patch looks reasonable. Minor comment bellow:
>
will use 'anon'.
> > - some cleanup and added comment.
> >
> > Signed-off-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
> > ---
> > include/linux/page_cgroup.h | 8 +-----
> > mm/memcontrol.c | 55 ++++++++++++++++++++++++++----------------
> > 2 files changed, 35 insertions(+), 28 deletions(-)
> >
> [...]
> > diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> > index fb2dfc3..de7721d 100644
> > --- a/mm/memcontrol.c
> > +++ b/mm/memcontrol.c
> [...]
> > @@ -2908,9 +2915,15 @@ void mem_cgroup_uncharge_page(struct page *page)
> >
> > void mem_cgroup_uncharge_cache_page(struct page *page)
> > {
> > + int ctype;
> > +
> > VM_BUG_ON(page_mapped(page));
> > VM_BUG_ON(page->mapping);
> > - __mem_cgroup_uncharge_common(page, MEM_CGROUP_CHARGE_TYPE_CACHE);
> > + if (page_is_file_cache(page))
> > + ctype = MEM_CGROUP_CHARGE_TYPE_CACHE;
> > + else
> > + ctype = MEM_CGROUP_CHARGE_TYPE_SHMEM;
> > + __mem_cgroup_uncharge_common(page, ctype);
>
> OK, this makes sense but doesn't make any real difference now, so it is
> more a clean up, right?
>
Yes. Johannes reuqested to remove this. I'll remove this in v3.
Thanks,
-Kame
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists