lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 19 Jan 2012 08:54:19 +0530
From:	Laxman Dewangan <>
To:	Mark Brown <>,
	Stephen Warren <>
CC:	"" <>,
	"" <>,
	"" <>
Subject: RE: [PATCH V1 2/2] regulator: tps65910: Initialize n_voltages for

> On Wednesday, January 18, 2012 11:26 PM, Mark Brown wrote:
> > > +		.table_len = 73,
> > >  	},
> > Forgive me if these comments are bogus since I'm not familiar with
> > regulators much, but:
> > a) Don't you want to use ARRAY_SIZE() instead of hard-coding table_len's
> > value?
> > b) Don't you need to set .table to actually point at the table too? If not,
> > isn't tps65910_list_voltage() going to dereference a NULL pointer, since
> > it will dereference .table if .table_len is set?
> It's not actually a table at all any more as the driver calculates the
> values, table_len is misnamed and should be renamed as well as set.

Do you want to rename the variable in this patch or in separate patch?
In place of table_len, I will say n_voltages as this is most common name
in regulator world.

> --
> To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
> the body of a message to
> More majordomo info at
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists