[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <4F2B5D25.1040601@hitachi.com>
Date: Fri, 03 Feb 2012 13:05:57 +0900
From: HAYASAKA Mitsuo <mitsuo.hayasaka.hu@...achi.com>
To: Christoph Hellwig <hch@...radead.org>
Cc: Ben Myers <bpm@....com>, Alex Elder <aelder@....com>,
Christoph Hellwig <hch@....de>, Alex Elder <elder@...nel.org>,
linux-kernel@...r.kernel.org, xfs@....sgi.com,
xfs-masters@....sgi.com
Subject: Re: [PATCH 3/3] xfs: cleanup quota check on disk blocks and inodes
reservations
Hi Christoph
Thank you for your comments.
(2012/02/03 1:07), Christoph Hellwig wrote:
> On Mon, Jan 23, 2012 at 12:45:43PM +0900, Mitsuo Hayasaka wrote:
>> This patch is a cleanup of quota check on disk blocks and inodes
>> reservations.
>>
>> Signed-off-by: Mitsuo Hayasaka <mitsuo.hayasaka.hu@...achi.com>
>> Cc: Ben Myers <bpm@....com>
>> Cc: Alex Elder <elder@...nel.org>
>> Cc: Christoph Hellwig <hch@....de>
>> ---
>>
>> fs/xfs/xfs_trans_dquot.c | 17 +++++++----------
>> 1 files changed, 7 insertions(+), 10 deletions(-)
>>
>> diff --git a/fs/xfs/xfs_trans_dquot.c b/fs/xfs/xfs_trans_dquot.c
>> index c4ba366..5e6cd1c 100644
>> --- a/fs/xfs/xfs_trans_dquot.c
>> +++ b/fs/xfs/xfs_trans_dquot.c
>> @@ -605,7 +605,7 @@ xfs_trans_dqresv(
>> time_t timer;
>> xfs_qwarncnt_t warns;
>> xfs_qwarncnt_t warnlimit;
>> - xfs_qcnt_t count;
>> + xfs_qcnt_t tcount;
>
> Can you call this variable total_count to make it a bit more obvious?
Sure.
>
>> + tcount = *resbcountp + nblks;
>> + if (hardlimit > 0ULL && tcount > hardlimit) {
>
> Given that xfs_qcnt_t is unsigned what about transforming this into the
> more readable:
>
> if (hardlimit && total_count > hardlimit)
>
> and similar for the others?
>
OK, I'm going to change them and send the revised patch series.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists