[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <86r4yatx8t.fsf@sumi.keithp.com>
Date: Sat, 04 Feb 2012 16:49:06 +0100
From: Keith Packard <keithp@...thp.com>
To: Alan Stern <stern@...land.harvard.edu>, Greg KH <greg@...ah.com>
Cc: Pavel Machek <pavel@....cz>, "Rafael J. Wysocki" <rjw@...k.pl>,
Kernel development list <linux-kernel@...r.kernel.org>,
USB list <linux-usb@...r.kernel.org>
Subject: Re: [PATCH] USB: debugging code shouldn't alter control flow
On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern <stern@...land.harvard.edu> wrote:
> - urb->transfer_flags &= allowed;
> + allowed &= urb->transfer_flags;
Minor bikeshed here, but 'allowed' is not the right name for the value
at this point; perhaps just
/* warn if submitter gave bogus flags */
if ((urb->transfer_flags & allowed) != urb->transfer_flags)
might be better?
Otherwise, this looks nice to me.
Acked-by: Keith Packard <keithp@...thp.com>
--
keith.packard@...el.com
Content of type "application/pgp-signature" skipped
Powered by blists - more mailing lists