lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 06 Feb 2012 12:07:40 -0500 (EST)
From:	David Miller <davem@...emloft.net>
To:	netdev@...deepdalvi.com
Cc:	netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v5 4/5] netdev: ethernet dev_alloc_skb to
 netdev_alloc_skb

From: "Pradeep A. Dalvi" <netdev@...deepdalvi.com>
Date: Sun,  5 Feb 2012 18:21:05 +0530

> From: Pradeep A Dalvi <netdev@...deepdalvi.com>
> 
> Replaced deprecating dev_alloc_skb with netdev_alloc_skb in drivers/net/ethernet
>   - Removed extra skb->dev = dev after netdev_alloc_skb
> 
> Signed-off-by: Pradeep A Dalvi <netdev@...deepdalvi.com>

I'm not applying this, you screw up the code formatting in too
many locations.

Do NOT take the output of checkpatch literally, look at the result
and determine on your own whether it looks reasonable or not:

> -		struct sk_buff *skb = dev_alloc_skb(np->rx_buf_sz + NV_RX_ALLOC_PAD);
> +		struct sk_buff *skb =
> +			netdev_alloc_skb(dev, np->rx_buf_sz + NV_RX_ALLOC_PAD);

This, looks like crap.  The longer line is better.

> -			struct sk_buff *skb = dev_alloc_skb(hmp->rx_buf_sz + 2);
> +			struct sk_buff *skb = netdev_alloc_skb(dev,
> +					hmp->rx_buf_sz + 2);

Same thing here.

> -			struct sk_buff *skb = dev_alloc_skb(yp->rx_buf_sz + 2);
> +			struct sk_buff *skb = netdev_alloc_skb(dev,
> +					yp->rx_buf_sz + 2);

Column line-up rule violated, and this looks like crap as a result.  The long
single line would look 100 times better.

And there are many other instances of this problem.

Here's my advice, just do the textual change of the function name and add
the network device argument, don't mess with the coding style at all.

You're fare much better than how these patches ended up in the cases where
you tried to "improve" things.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ