[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <23e491f9-cb12-4bba-b5b0-a9948b17c984@zimbra>
Date: Fri, 17 Feb 2012 16:03:48 -0600 (CST)
From: Aaron Sierra <asierra@...-inc.com>
To: Jean Delvare <khali@...ux-fr.org>
Cc: Guenter Roeck <guenter@...ck-us.net>,
Peter Tyser <ptyser@...-inc.com>,
Grant Likely <grant.likely@...retlab.ca>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/3 v3] mfd: Add LPC driver for Intel ICH chipsets
> > +static void __devexit lpc_ich_remove(struct pci_dev *dev)
> > +{
> > + mfd_remove_devices(&dev->dev);
> > +
> > + if (lpc_ich_gpio_save > 0)
> > + pci_write_config_byte(dev, GPIOCTRL, (u8)lpc_ich_gpio_save);
> > + if (lpc_ich_acpi_save > 0)
> > + pci_write_config_byte(dev, ACPICTRL, (u8)lpc_ich_acpi_save);
>
> I think you really mean >= 0 above. And the casts aren't needed. You
> should also reset lpc_ich_gpio_save and lpc_ich_acpi_save to -1 after
> restoring the values, it matters if the device is removed and re-added
> through sysfs.
I seriously almost changed that compare in this patch... I wish I had. I've
made these changes, now.
> This cleanup is missing from the error path in lpc_ich_probe, BTW.
> You may want to move it to a separate function so that you can call it
> from both lpc_ich_probe and lpc_ich_remove.
Good point. I've got this change ready to go, too. Thanks.
-Aaron S.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists