lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 19 Feb 2012 22:17:09 +0100
From:	Holger Macht <holger@...ac.de>
To:	Jiri Slaby <jslaby@...e.cz>
Cc:	Jeff Garzik <jgarzik@...ox.com>, linux-ide@...r.kernel.org,
	LKML <linux-kernel@...r.kernel.org>,
	Jiri Slaby <jirislaby@...il.com>,
	Lin Ming <ming.m.lin@...el.com>
Subject: Re: ahci: sata hotplug doesn't work after suspend

On So 19. Feb - 21:11:33, Jiri Slaby wrote:
> Hi,
> 
> ahci hotplug stopped working here. It always worked (-next-20111206 is
> the last known working for sure). I'm using -next and after plugging a
> sata disk in, nothing happens. I don't *think* (in the traffic, it's
> hard to tell for sure) an interrupt is generated either. I also *think*
> that it works before suspend/resume, but not after. (Or maybe uptime
> matters?)
> 
> This happens before suspend on plug-in:
> ata3: exception Emask 0x50 SAct 0x0 SErr 0x40d0800 action 0xe frozen
> ata3: irq_stat 0x00000040, connection status changed
> ata3: SError: { HostInt PHYRdyChg CommWake 10B8B DevExch }
> ata3: hard resetting link
> ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
> ata3.00: ATA-8: ST31000528AS, CC38, max UDMA/133
> ata3.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
> ata3.00: configured for UDMA/133
> ata3: EH complete
> scsi 2:0:0:0: Direct-Access     ATA      ST31000528AS     CC38 PQ: 0 ANSI: 5
> sd 2:0:0:0: [sdc] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
> sd 2:0:0:0: [sdc] Write Protect is off
> sd 2:0:0:0: [sdc] Mode Sense: 00 3a 00 00
> sd 2:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't
> support DPO or FUA
>  sdc: sdc1 sdc2
> sd 2:0:0:0: [sdc] Attached SCSI disk
> 
> After suspend/resume and plug-in, nothing appears in dmesg. Storing "- -
> -" to /sys/class/scsi_host/host*/scan doesn't help. It looks like the
> line is completely dead, because only ata1 and ata2 say "hard resetting
> link" after this (and another two disks are connected there).
> 
> I tried 'echo adapter >host_reset', but I get 'write error: Invalid
> argument'.
> 
> 00:1f.2 SATA controller [0106]: Intel Corporation 82801IR/IO/IH
> (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] [8086:2922] (rev 02)
> (prog-if 01 [AHCI 1.0])
>         Subsystem: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port
> SATA Controller [AHCI mode] [8086:2922]
>         Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
> ParErr- Stepping- SERR- FastB2B- DisINTx+
>         Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
> <TAbort- <MAbort- >SERR- <PERR- INTx-
>         Latency: 0
>         Interrupt: pin B routed to IRQ 43
>         Region 0: I/O ports at cc00 [size=8]
>         Region 1: I/O ports at c880 [size=4]
>         Region 2: I/O ports at c800 [size=8]
>         Region 3: I/O ports at c480 [size=4]
>         Region 4: I/O ports at c400 [size=32]
>         Region 5: Memory at feb7c800 (32-bit, non-prefetchable) [size=2K]
>         Capabilities: [80] MSI: Enable+ Count=1/16 Maskable- 64bit-
>                 Address: fee0100c  Data: 4171
>         Capabilities: [70] Power Management version 3
>                 Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
> PME(D0-,D1-,D2-,D3hot+,D3cold-)
>                 Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
>         Capabilities: [a8] SATA HBA v1.0 BAR4 Offset=00000004
>         Capabilities: [b0] Vendor Specific Information: Len=06 <?>
>         Kernel driver in use: ahci
> 
> Any ideas what that could be?

I suspect this is caused by commit
9ee4f3933930abf5cc34f8e9d69fe0e08c18f602. Maybe you could verify? I
bisected this a couple of days ago but didn't have time to look into it
further. Maybe Lin can help here if this is the problematic commit.

Regards,
 Holger
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists