lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 23 Feb 2012 09:18:21 -0800
From:	Linus Torvalds <>
To:	Ingo Molnar <>
Cc:	Paul Mackerras <>,
	"H. Peter Anvin" <>,
	Steven Rostedt <>,
	Jason Baron <>,,,,,,
Subject: Re: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs

On Thu, Feb 23, 2012 at 2:02 AM, Ingo Molnar <> wrote:
> Having to take the address gives us type safety - i.e. it will
> not be possible to accidentally pass in a non-jump-label key and
> get it misinterpreted.

Ingo, stop with the stupid denialism.

NOBODY likes that name. NOBODY. It's wrong. It's stupid. It sounds
like a stronger "unlikely()", and it simply IS NOT.

So rename it already.

The "type safety" argument seems bogus too. As far as I can tell, it
fails miserably if you test a void pointer for being NULL.

Sure, you can fix that by doing crazy things to the interface, but in
the end, nothing changes the fact that "very_unlikely()" as a name
sounds like an emphatic version of "unlikely()".

Rename it. Make it clear from the name that it is about these static
variables. Everything else seems to be named for that "static_key"
thing, so make the testing of it be named that way too, instead of
using a bad generic naming scheme that is just confusing.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists