lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 23 Feb 2012 14:45:53 -0800
From:	Linus Torvalds <>
To:	Ingo Molnar <>
Cc:	Paul Mackerras <>,
	"H. Peter Anvin" <>,
	Steven Rostedt <>,
	Jason Baron <>,,,,,,
Subject: Re: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs

On Thu, Feb 23, 2012 at 2:33 PM, Ingo Molnar <> wrote:
> At the risk of being flamed some more, where does the confusion
> stem from?

>From the fact that "very" is an English word that means "very", and
"unlikely()" and "likely()" are already used in their obvious meaning.

So quite frankly, "very_unlikely()" quite naturally means something
else than you are trying to make it mean.

The fact that EVERY SINGLE OTHER OPERATION that worked on that data
structure used to be named "jump_label_xyz()" and is  now named
"static_key_xyz()" is also a big clue, I think. Naming it anything
else was always a mistake.

Seriously, I don't understand why you don't just use the obvious name.
The data structure is named "static_key". The things that change it
are named "static_key_inc()" or something. So a name like
"static_key_true()" is simply *better*, isn't it?

It's not just about less confusion, it's actually about just having
consistent naming.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists