lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Wed, 22 Feb 2012 16:13:55 -0800
From:	"H. Peter Anvin" <hpa@...or.com>
To:	Hitoshi Mitake <h.mitake@...il.com>
CC:	Rusty Russell <rusty@...tcorp.com.au>, Ingo Molnar <mingo@...e.hu>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: segmentation fault of modpost

On 02/21/2012 11:17 PM, Hitoshi Mitake wrote:
> Hi,
> 
> I tried to build tip-tree with allmodconfig and ARCH=i386 on x86_64 machine.
> And modpost caused segmentation fault like this:
> modpost[23652]: segfault at 2b53bece3000 ip 00000000004030bb sp
> 00007ffffad8d260 error 4 in modpost[400000+d000]
> # from dmesg
> 
> The commit of -tip tree is 64256eb8e9f8cd53100ee6142968df336c54eb32.
> 
> Is this problem already reported or solved?
> If not, I'd like to solve this because I need to build all{mod,yes}config
> kernel for testing readq/writeq of x86.
> 

I cannot reproduce this on a Fedora 15 development system.  I have to
turn off two modules:

CONFIG_SCx200HR_TIMER=n
CONFIG_ANDROID_BINDER_IPC=n

... but modpost runs just fine.  It would be good if you could compile
modpost with -g and see where in the code the failure happens.

	-hpa

-- 
H. Peter Anvin, Intel Open Source Technology Center
I work for Intel.  I don't speak on their behalf.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists