[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20120309190842.GC13745@aftab>
Date: Fri, 9 Mar 2012 20:08:42 +0100
From: Borislav Petkov <bp@...64.org>
To: Kees Cook <keescook@...omium.org>
Cc: "H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...e.hu>,
linux-kernel@...r.kernel.org, Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, x86@...nel.org,
Andy Lutomirski <luto@....edu>,
Hidetoshi Seto <seto.hidetoshi@...fujitsu.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Mike Frysinger <vapier@...too.org>,
Steven Rostedt <rostedt@...dmis.org>,
Peter Zijlstra <a.p.zijlstra@...llo.nl>
Subject: Re: [PATCH] x86: use enum instead of literals for trap values
On Fri, Mar 09, 2012 at 10:54:19AM -0800, Kees Cook wrote:
> On Fri, Mar 9, 2012 at 10:28 AM, Borislav Petkov <bp@...64.org> wrote:
> > On Fri, Mar 09, 2012 at 10:21:52AM -0800, Kees Cook wrote:
> >> > I have to admit personally to prefer something like X86_XCP_XX where XX
> >> > is the two-letter code that the Intel documentation uses for that trap,
> >> > i.e. #GP, #BR, #MC and so on.
> >>
> >> We need a single person to decide on this bike shed color. :) If the
> >> list of enum names can be agreed on, I'll be happy to do the
> >> search/replace for it.
> >
> > Well,
> >
> > here are my 2ยข: I agree with hpa because
> >
> > a) it maps the CPU vendor documentation
> > b) it is nicely short
>
> How about:
>
> X86_XCP_DE = 0, /* 0, Divide-by-zero */
> X86_XCP_DB, /* 1, Debug */
> X86_XCP_NMI, /* 2, Non-maskable Interrupt */
> X86_XCP_BP, /* 3, Breakpoint */
> X86_XCP_OF, /* 4, Overflow */
> X86_XCP_BR, /* 5, Bound Range Exceeded */
> X86_XCP_UD, /* 6, Invalid Opcode */
> X86_XCP_NM, /* 7, Device Not Available */
> X86_XCP_DF, /* 8, Double Fault */
> X86_XCP_OLD_MF, /* 9, Coprocessor Segment Overrun */
> X86_XCP_TS, /* 10, Invalid TSS */
> X86_XCP_NP, /* 11, Segment Not Present */
> X86_XCP_SS, /* 12, Stack-Segment Fault */
> X86_XCP_GP, /* 13, General Protection Fault */
> X86_XCP_PF, /* 14, Page Fault */
> X86_XCP_RES, /* 15, Reserved */
So is this reserved or are we using it for Spurious IRQs? If we use it,
then 'RES' is a bad name. Maybe we define our own like
X86_VEC_SP
and then do
X86_VEC_IR for IRET
in the manner we assumed for the rest?
> X86_XCP_MF, /* 16, x87 Floating-Point Exception */
> X86_XCP_AC, /* 17, Alignment Check */
> X86_XCP_MC, /* 18, Machine Check */
> X86_XCP_XM, /* 19, SIMD Floating-Point Exception */
Shouln't this be #XF actually? At least it is so in the AMD docs.
> X86_XCP_IRET = 32, /* 32, IRET Exception */
>
> There is a name collision for "MF", there's no mnemonic for NMI,
Well, in the AMD docs we actually do have the '#NMI' mnemonic in use.
> IRET, or the reserved "spurious" interrupt.
>
> Can use "VEC" instead "XCP", as Steven suggests.
Yeah, because those actually are fixed interrupt vectors, as they're
called in the AMD docs. Makes sense.
Thanks.
--
Regards/Gruss,
Boris.
Advanced Micro Devices GmbH
Einsteinring 24, 85609 Dornach
GM: Alberto Bozzo
Reg: Dornach, Landkreis Muenchen
HRB Nr. 43632 WEEE Registernr: 129 19551
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists