lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 13 Mar 2012 08:09:06 -0400
From:	Christoph Hellwig <hch@...radead.org>
To:	Miklos Szeredi <miklos@...redi.hu>
Cc:	viro@...IV.linux.org.uk, linux-fsdevel@...r.kernel.org,
	linux-kernel@...r.kernel.org, hch@...radead.org,
	Trond.Myklebust@...app.com, sfrench@...ba.org, sage@...dream.net,
	ericvh@...il.com, mszeredi@...e.cz
Subject: Re: [PATCH 09/25] nfs: remove nfs4 specific create function

On Wed, Mar 07, 2012 at 10:22:26PM +0100, Miklos Szeredi wrote:
> From: Miklos Szeredi <mszeredi@...e.cz>
> 
> Make nfs_atomic_open() work for non-open creates.  This is trivial to do and
> allows the NFSv4 specific create code to be removed.
> 
> Signed-off-by: Miklos Szeredi <mszeredi@...e.cz>
> ---
>  fs/nfs/dir.c      |   28 ++++++++++++++++++++--------
>  fs/nfs/nfs4proc.c |   31 -------------------------------
>  2 files changed, 20 insertions(+), 39 deletions(-)
> 
> diff --git a/fs/nfs/dir.c b/fs/nfs/dir.c
> index 24bf3c9..8627965 100644
> --- a/fs/nfs/dir.c
> +++ b/fs/nfs/dir.c
> @@ -114,10 +114,13 @@ const struct inode_operations nfs3_dir_inode_operations = {
>  static struct file *nfs_atomic_open(struct inode *, struct dentry *,
>  				    struct opendata *, unsigned, umode_t,
>  				    bool *);
> +static struct file *nfs_atomic_open_common(struct inode *, struct dentry *,
> +					   struct opendata *, unsigned,
> +					   umode_t);
>  const struct inode_operations nfs4_dir_inode_operations = {
> -	.create		= nfs_create,
>  	.lookup		= nfs_lookup,
>  	.atomic_open	= nfs_atomic_open,
> +	.atomic_create	= nfs_atomic_open_common, /* called for mknod */

Can you please name the methods after the interface they implement,
e.g. do a s/nfs_atomic_open_common/nfs_atomic_create/g here, and
similar transformations for the other filesystems.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ