[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20120315170350.GB11441@oksana.dev.rtsoft.ru>
Date: Thu, 15 Mar 2012 21:03:50 +0400
From: Anton Vorontsov <cbouatmailru@...il.com>
To: Axel Lin <axel.lin@...il.com>
Cc: linux-kernel@...r.kernel.org,
MyungJoo Ham <myungjoo.ham@...sung.com>,
Kyungmin Park <kyungmin.park@...sung.com>,
Donggeun Kim <dg77.kim@...sung.com>
Subject: Re: [PATCH] power_supply: charger-manager: Clean up for better
readability
On Thu, Jan 12, 2012 at 12:56:35PM +0800, Axel Lin wrote:
> This patch includes below changes:
>
> * Some code change for better readability.
> * Current code in probe already ensures desc->charger_regulators is not NULL.
> No need to check if it is NULL or not before calling regulator_bulk_free().
> * Use dev_get_drvdata() in cm_suspend_prepare() and cm_suspend_complete()
>
> Signed-off-by: Axel Lin <axel.lin@...il.com>
> ---
Applied, thanks a lot!
FWIW, I also applied the following patch:
commit f304f0a31442f4c8b98208acedc3da2f6c60a771
Author: Anton Vorontsov <anton.vorontsov@...aro.org>
Date: Thu Mar 15 21:01:28 2012 +0400
charger-manager: Simplify charger_get_property(), get rid of a warning
This patch fixes the following warning and makes the code a little
bit more simpler:
CC drivers/power/charger-manager.o
charger-manager.c: In function 'charger_get_property':
charger-manager.c:429:15: warning: 'i' may be used uninitialized in this function [-Wuninitialized]
Signed-off-by: Anton Vorontsov <anton.vorontsov@...aro.org>
diff --git a/drivers/power/charger-manager.c b/drivers/power/charger-manager.c
index e610e6b..9eca9f1 100644
--- a/drivers/power/charger-manager.c
+++ b/drivers/power/charger-manager.c
@@ -399,7 +399,8 @@ static int charger_get_property(struct power_supply *psy,
struct charger_manager *cm = container_of(psy,
struct charger_manager, charger_psy);
struct charger_desc *desc = cm->desc;
- int i, ret = 0, uV;
+ int ret = 0;
+ int uV;
switch (psp) {
case POWER_SUPPLY_PROP_STATUS:
@@ -425,8 +426,7 @@ static int charger_get_property(struct power_supply *psy,
val->intval = 0;
break;
case POWER_SUPPLY_PROP_VOLTAGE_NOW:
- ret = get_batt_uV(cm, &i);
- val->intval = i;
+ ret = get_batt_uV(cm, &val->intval);
break;
case POWER_SUPPLY_PROP_CURRENT_NOW:
ret = cm->fuel_gauge->get_property(cm->fuel_gauge,
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists