[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <m17gy2mufa.fsf@fess.ebiederm.org>
Date: Fri, 30 Mar 2012 00:15:05 -0700
From: ebiederm@...ssion.com (Eric W. Biederman)
To: Alexander Gordeev <agordeev@...hat.com>
Cc: "H. Peter Anvin" <hpa@...or.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] x86, acpi/irq: Minor readability cleanup of gsi_to_irq()
Alexander Gordeev <agordeev@...hat.com> writes:
> Init value of 'irq' variable is never used. So do not initialize it.
Reviewed-by: "Eric W. Biederman" <ebiederm@...ssion.com>
> Signed-off-by: Alexander Gordeev <agordeev@...hat.com>
> ---
Looks good to me. I was going to ask what idiot wrote that silly
thing but it appears that idiot was me. I must have rewritten
the function and forgotten to cleanup that initial assignment to irq.
That change makes it much clearer what is going on thank you.
Eric
> arch/x86/kernel/acpi/boot.c | 10 ++++------
> 1 files changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/arch/x86/kernel/acpi/boot.c b/arch/x86/kernel/acpi/boot.c
> index 406ed77..f148557 100644
> --- a/arch/x86/kernel/acpi/boot.c
> +++ b/arch/x86/kernel/acpi/boot.c
> @@ -103,13 +103,11 @@ static u32 isa_irq_to_gsi[NR_IRQS_LEGACY] __read_mostly = {
>
> static unsigned int gsi_to_irq(unsigned int gsi)
> {
> - unsigned int irq = gsi + NR_IRQS_LEGACY;
> - unsigned int i;
> + unsigned int irq;
>
> - for (i = 0; i < NR_IRQS_LEGACY; i++) {
> - if (isa_irq_to_gsi[i] == gsi) {
> - return i;
> - }
> + for (irq = 0; irq < NR_IRQS_LEGACY; irq++) {
> + if (isa_irq_to_gsi[irq] == gsi)
> + return irq;
> }
>
> /* Provide an identity mapping of gsi == irq
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists