[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4F9976AB.1020502@wwwdotorg.org>
Date: Thu, 26 Apr 2012 10:24:11 -0600
From: Stephen Warren <swarren@...dotorg.org>
To: Dong Aisheng <b29396@...escale.com>
CC: linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
devicetree-discuss@...ts.ozlabs.org, linus.walleij@...ricsson.com,
s.hauer@...gutronix.de, shawn.guo@...escale.com,
kernel@...gutronix.de, grant.likely@...retlab.ca,
rob.herring@...xeda.com, cjb@...top.org, b20223@...escale.com
Subject: Re: [PATCH v4 1/4] dt: add of_get_child_count helper function
On 04/26/2012 08:40 AM, Dong Aisheng wrote:
> From: Dong Aisheng <dong.aisheng@...aro.org>
>
> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.
> diff --git a/include/linux/of.h b/include/linux/of.h
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> + struct device_node *child = NULL;
You don't actually need to initialize child here. It doesn't really
matter here, but in a more complex function, it might hide a
used-before-initialized error.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists