[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1337546284.31503.5.camel@joe2Laptop>
Date: Sun, 20 May 2012 13:38:04 -0700
From: Joe Perches <joe@...ches.com>
To: David Rientjes <rientjes@...gle.com>
Cc: Nasir Abed <nasirabed@...il.com>, gregkh@...uxfoundation.org,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org,
swetland@...gle.com, Nasir Abed <nasirabed+kernel@...il.com>
Subject: Re: [PATCH] Staging: android: alarm: fixed quoted string split
across lines
On Sun, 2012-05-20 at 13:28 -0700, David Rientjes wrote:
> On Sun, 20 May 2012, Nasir Abed wrote:
>
> > diff --git a/drivers/staging/android/alarm.c b/drivers/staging/android/alarm.c
> > index c68950b..4ea07bb 100644
> > --- a/drivers/staging/android/alarm.c
> > +++ b/drivers/staging/android/alarm.c
> > @@ -302,8 +302,8 @@ int android_alarm_set_rtc(struct timespec new_time)
> > }
> > ret = rtc_set_time(alarm_rtc_dev, &rtc_new_rtc_time);
> > if (ret < 0)
> > - pr_alarm(ERROR, "alarm_set_rtc: "
> > - "Failed to set RTC, time will be lost on reboot\n");
> > + pr_alarm(ERROR,
> > + "alarm_set_rtc: Failed to set RTC, time will be lost on reboot\n");
> > err:
> > wake_unlock(&alarm_rtc_wake_lock);
> > mutex_unlock(&alarm_setrtc_mutex);
>
> Looks like this would benefit from using __func__ since it already doesn't
> represent the correct function name.
true.
Somewhat related, pr_alarm is a poor name choice.
It should probably called alarm_dbg.
o it's a duplicated #define
it should be in some common #include
o it's a debug test that emits at KERN_INFO
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists