[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-id: <4FD57C87.7000404@samsung.com>
Date: Mon, 11 Jun 2012 14:05:11 +0900
From: jonghwa3.lee@...sung.com
To: Arnd Bergmann <arnd@...db.de>
Cc: linux-kernel@...r.kernel.org,
Mike Turquette <mturquette@...aro.org>,
H Hartley Sweeten <hsweetn@...ionengravers.com>,
Mark Brown <broonie@...nsource.wolfsonmicro.com>,
MyungJoo Ham <myungjoo.ham@...sung.com>,
Kyungmin Park <kyungmin.park@...sung.com>
Subject: Re: [PATCH] clock: max77686: Add driver for Maxim 77686 32KHz crystal
oscillator
Hi, Arnd.
Sorry for that reply is late. I had some personal reasons so i couldn't
check e-mail all last week. I just read your comments today.
On 2012년 06월 02일 01:13, Arnd Bergmann wrote:
> On Friday 01 June 2012, Jonghwa Lee wrote:
>> +
>> +#ifdef COMMON_CONFIG_CLK
>
> Two comments on this one:
>
> 1. It should be CONFIG_COMMON_CLK, not COMMON_CONFIG_CLK, I suppose. The symbol
> you are testing for is never defined so your code does not even get built.
> I suppose you did not test the version you are sending ...
>
> 2. There is no use in enclosing an entire file in #ifdef. Instead, make the Kconfig
> symbol depend on COMMON_CLK.
>
I did build test only without #ifdef statement before upload. And i
wrote this line right before send the code. I made mistake at that time.
Anyway, I'll change this condition as you commented.
>> +#define to_max77686_clk(__name) container_of(hw, \
>> + struct max77686_clk, __name)
>
> This use of container_of() is very unusual and confusing, because the argument
> into your macro is the member of the struct, not the variable that you are basing
> from. You should not need the macro at all, so please try to remove it.
>
Yes, i agree that this macro makes some confuse.
>> +struct max77686_clk {
>> + struct max77686_dev *iodev;
>> + struct clk_hw clk32khz_ap_hw;
>> + struct clk_hw clk32khz_cp_hw;
>> + struct clk_hw clk32khz_pmic_hw;
>> +};
>> +
>> +static struct clk *clk32khz_ap;
>> +static struct clk *clk32khz_cp;
>> +static struct clk *clk32khz_pmic;
>> +static char *max77686_clk[] = {
>> + "32khap",
>> + "32khcp",
>> + "p32kh",
>> +};
>
> With these static definitions, you can only have a single max77686 device in the
> system. Better remove these symbols.
Okay, I'll apply it.
>
>> +static struct max77686_clk *get_max77686_clk(struct clk_hw *hw)
>> +{
>> + struct clk *clk = hw->clk;
>> + if (clk == clk32khz_ap)
>> + return to_max77686_clk(clk32khz_ap_hw);
>> + else if (clk == clk32khz_cp)
>> + return to_max77686_clk(clk32khz_cp_hw);
>> + else if (clk == clk32khz_pmic)
>> + return to_max77686_clk(clk32khz_pmic_hw);
>> + else
>> + return NULL;
>> +}
>
> I can only assume that you meant this to be
>
> struct max77686_clk {
> struct max77686_dev *iodev;
> u32 mask;
> struct clk_hw hw;
> };
> static struct max77686_clk *get_max77686_clk(struct clk_hw *hw)
> {
> return container_of(hw, struct max77686_clk, hw)->iodev;
> }
>
> You probably misunderstood the person who was suggesting you use
> container_of(). Note that this function is so simple that you
> probably don't even need it: just open-code the container_of.
>
I think to_max77686_clk macro makes you uncomfortable, I'll modify them
with considering your comments. And your get_max77668_clk() return wrong
type pointer since it has to return struct max77696_clk pointer.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists