[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <500DB960.6020802@wwwdotorg.org>
Date: Mon, 23 Jul 2012 14:51:44 -0600
From: Stephen Warren <swarren@...dotorg.org>
To: Laxman Dewangan <ldewangan@...dia.com>
CC: broonie@...nsource.wolfsonmicro.com, ccross@...roid.com,
olof@...om.net, lrg@...com, thierry.reding@...onic-design.de,
linux-kernel@...r.kernel.org, linux-tegra@...r.kernel.org,
linux-doc@...r.kernel.org, devicetree-discuss@...ts.ozlabs.org,
rob.herring@...xeda.com, grant.likely@...retlab.ca
Subject: Re: [PATCH 2/2] regulator: tps6586x: add support for input supply
On 07/13/2012 07:50 AM, Laxman Dewangan wrote:
> There is multiple voltage input pins on device which
> takes the voltage input for different voltage regulator.
> Support to configure the voltage input supplied by
> different regulator for each regulators.
>
> Signed-off-by: Laxman Dewangan <ldewangan@...dia.com>
> ---
> .../devicetree/bindings/regulator/tps6586x.txt | 17 +++++++
> drivers/regulator/tps6586x-regulator.c | 47 ++++++++++---------
> 2 files changed, 42 insertions(+), 22 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/regulator/tps6586x.txt b/Documentation/devicetree/bindings/regulator/tps6586x.txt
> index ab17ef6..d156e1b 100644
> --- a/Documentation/devicetree/bindings/regulator/tps6586x.txt
> +++ b/Documentation/devicetree/bindings/regulator/tps6586x.txt
> @@ -9,6 +9,14 @@ Required properties:
> - regulators: list of regulators provided by this controller, must have
> property "regulator-compatible" to match their hardware counterparts:
> sm[0-2], ldo[0-9] and ldo_rtc
> +- sm0-supply: The input supply for the SM0.
> +- sm1-supply: The input supply for the SM1.
> +- sm2-supply: The input supply for the SM2.
> +- vinldo01-supply: The input supply for the LDO1 and LDO2
> +- vinldo23-supply: The input supply for the LDO2 and LDO3
> +- vinldo4-supply: The input supply for the LDO4
> +- vinldo678-supply: The input supply for the LDO6, LDO7 and LDO8
> +- vinldo9-supply: The input supply for the LDO9
Hmm. The signal names in my data sheet are VIN_SMn and VINLDOn, so
having "vin" in just some of the property names seems a little inconsistent.
> diff --git a/drivers/regulator/tps6586x-regulator.c b/drivers/regulator/tps6586x-regulator.c
> static inline struct device *to_tps6586x_dev(struct regulator_dev *rdev)
> {
> - return rdev_get_dev(rdev)->parent->parent;
> + return rdev_get_dev(rdev)->parent;
...
> @@ -351,7 +354,7 @@ static int __devinit tps6586x_regulator_probe(struct platform_device *pdev)
...
> - config.dev = &pdev->dev;
> + config.dev = pdev->dev.parent;
Those seem like unrelated changes, but I suppose it's fine.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists