lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1343215699-4575-1-git-send-email-avinashphilip@ti.com>
Date:	Wed, 25 Jul 2012 16:58:17 +0530
From:	"Philip, Avinash" <avinashphilip@...com>
To:	<thierry.reding@...onic-design.de>
CC:	<linux-kernel@...r.kernel.org>, <nsekhar@...com>,
	<vaibhav.bedia@...com>, <gururaja.hebbar@...com>,
	"Philip, Avinash" <avinashphilip@...com>
Subject: [PATCH v2 0/2] PWM driver support for EHRPWM & ECAP

This patch series adds support for PWM driver support for EHRPWM
and ECAP modules which has been present on AM335x SOC. AM335X SOC has 3
instances of ECAP & EHRPWM.

EHRPWM device can be used to generate PWM waveforms. It has 2 channels
of PWM output and each can be configured for different duty cycle and
polarity.

ECAP device can be used as either Capture or APWM mode. In APWM mode,
ECAP can generate PWM waveform.

Patch #1 adds Generic PWM driver support for simple APWM functionality
of ECAP ECAP hardware.

Patch #2 adds  PWM driver support for EHRPWM device.

This patch series is based on new PWM framework maintained at [1].

1. https://gitorious.org/linux-pwm/linux-pwm/trees/for-next

Since v1:
	- Alphabetically placed in Kconfig and Makefile
	- Removes unused MACROS
	- Starts using TI prefix for ecap & ehrpwm modules to avoid
	  confusion.
	- Starts using platform_get_resource() instead of
	  platform_get_resource_byname()
	- Removes dev_info messages of PWM device Initialized.
	- Add const qualifier on struct pwm_ops definition.
	- Removes platform_drvdata check on platform_driver_remove.
	- Starts checking pwmchip_remove() return value.
	- Kept back MACRO definitions which are related to give more
	  readability

Philip, Avinash (2):
  pwm: pwm-tiecap: PWM driver support for ECAP APWM
  pwm: pwm-tiehrpwm: PWM driver support for EHRPWM

 drivers/pwm/Kconfig        |   22 +++
 drivers/pwm/Makefile       |    2 +
 drivers/pwm/pwm-tiecap.c   |  232 +++++++++++++++++++++++++
 drivers/pwm/pwm-tiehrpwm.c |  411 ++++++++++++++++++++++++++++++++++++++++++++
 4 files changed, 667 insertions(+), 0 deletions(-)
 create mode 100644 drivers/pwm/pwm-tiecap.c
 create mode 100644 drivers/pwm/pwm-tiehrpwm.c

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ