lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 26 Jul 2012 15:00:17 +0100
From:	Lee Jones <lee.jones@...aro.org>
To:	Mark Brown <broonie@...nsource.wolfsonmicro.com>
CC:	linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
	STEricsson_nomadik_linux@...t.st.com, linus.walleij@...ricsson.com,
	arnd@...db.de, sameo@...ux.intel.com, olalilja@...oo.se,
	ola.o.lilja@...ricsson.com, alsa-devel@...a-project.org, lrg@...com
Subject: Re: [PATCH 20/21] ASoC: codecs: Enable AB8500 CODEC for Device Tree

On 26/07/12 12:50, Mark Brown wrote:
> On Thu, Jul 26, 2012 at 11:28:53AM +0100, Lee Jones wrote:
>
>>   drivers/mfd/ab8500-core.c               |    1 +
>>   include/linux/mfd/abx500/ab8500-codec.h |    6 ++-
>>   sound/soc/codecs/ab8500-codec.c         |   79 +++++++++++++++++++++++++++++++
>>   3 files changed, 84 insertions(+), 2 deletions(-)
>
> Yet again no binding documentation....

RFC. ;)

I'll write the documentation when/if the properties are accepted.

>>   	{
>>   		.name = "ab8500-codec",
>> +		.of_compatible = "stericsson,ab8500-codec",
>>   	},
>
> Why are we doing this?  The MFD cells are a totally Linux specific
> thing, there's no reason to represent them in the device tree unless
> they're in some way reusable and the "ab8500-codec" name suggests that's
> unlikely.  Just put the properties on the parent node and instantiate
> the MFD cell as normal.
>
>> +	/* Has a non-standard Vamic been requested? */
>> +	if(of_get_property(np, "stericsson,amic1a-bias-vamic2", NULL))
>
> Coding style.

Missing space? Sorry, typo, I'll change.

>> +	if (!of_property_read_u32(np, "stericsson,earpeice-cmv", &value)) {
>> +		switch (value) {
>> +		case 950 :
>> +			codec->ear_cmv = EAR_CMV_0_95V;
>> +			break;
>> +		case 1100 :
>> +			codec->ear_cmv = EAR_CMV_1_10V;
>> +			break;
>> +		case 1270 :
>> +			codec->ear_cmv = EAR_CMV_1_27V;
>> +			break;
>> +		case 1580 :
>> +			codec->ear_cmv = EAR_CMV_1_58V;
>> +			break;
>> +		default :
>> +			codec->ear_cmv = EAR_CMV_UNKNOWN;
>> +			dev_err(dev, "Unsuitable earpiece voltage found in DT\n");
>
> The platform data code picks a default, can't the DT code do the same?

No, I don't think that it does? The original code returns -EINVAL unless 
a value is specified.

The original author is keen to have a clear error message in case users 
try to specify non-exact values. I'd rather we fail-out than use 
incorrect values which would be a great deal harder for a user to debug.

-- 
Lee Jones
Linaro ST-Ericsson Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ