[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LNX.2.01.1208031650580.3676@frira.zrqbmnf.qr>
Date: Fri, 3 Aug 2012 16:52:03 +0200 (CEST)
From: Jan Engelhardt <jengelh@...i.de>
To: "Steven J. Magnani" <steve@...idescorp.com>
cc: OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] fat: Refactor shortname parsing
On Tuesday 2012-07-03 13:14, Steven J. Magnani wrote:
>Nearly identical shortname parsing is performed in fat_search_long()
>and __fat_readdir(). Extract this code into a function that may be
>called by both.
>
>v2: Attempt to clarify difference between vfat and msdos parsing.
> Remove decision-making from fat_tolower() for clarity.
>
>Signed-off-by: Steven J. Magnani <steve@...idescorp.com>
>---
>diff -uprN linux-3.5-rc4/fs/fat/dir.c new/fs/fat/dir.c
>--- linux-3.5-rc4/fs/fat/dir.c 2012-06-29 11:20:12.766348728 -0500
>+++ new/fs/fat/dir.c 2012-07-03 06:10:36.066283411 -0500
>@@ -35,6 +35,11 @@
> #define FAT_MAX_UNI_CHARS ((MSDOS_SLOTS - 1) * 13 + 1)
> #define FAT_MAX_UNI_SIZE (FAT_MAX_UNI_CHARS * sizeof(wchar_t))
>
>+static inline unsigned char fat_tolower(unsigned char c)
>+{
>+ return ((c >= 'A') && (c <= 'Z')) ? c+32 : c;
>+}
>+
The kernel already has a tolower() function, can that not be used?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists