[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAErSpo66quAss14Hcdq7o3RSuR=DsE6xjyp=Eah=-XxtDRMTgQ@mail.gmail.com>
Date: Wed, 15 Aug 2012 14:21:28 -0600
From: Bjorn Helgaas <bhelgaas@...gle.com>
To: Jiang Liu <jiang.liu@...wei.com>
Cc: Yinghai Lu <yinghai@...nel.org>,
Kenji Kaneshige <kaneshige.kenji@...fujitsu.com>,
Jiang Liu <liuj97@...il.com>,
Taku Izumi <izumi.taku@...fujitsu.com>,
Don Dutile <ddutile@...hat.com>,
Greg KH <gregkh@...uxfoundation.org>,
Yijing Wang <wangyijing@...wei.com>,
Keping Chen <chenkeping@...wei.com>, linux-pci@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [RFC PATCH v1 1/6] PCI: change PCI device management logic to
better follow device model
On Sun, Jun 3, 2012 at 11:16 PM, Jiang Liu <jiang.liu@...wei.com> wrote:
> From: Jiang Liu <liuj97@...il.com>
>
> According to device model documentation, the way to add/remove device
> object should be symmetric.
I think this 6-patch series has been folded into your "[RFC PATCH v1
00/22] introduce PCI bus lock to serialize PCI hotplug operations"
series posted August 8, right?
I'll ignore these 6 patches on that assumption, so let me know if otherwise.
> /**
> * device_del - delete device from system.
> * @dev: device.
> *
> * This is the first part of the device unregistration
> * sequence. This removes the device from the lists we control
> * from here, has it removed from the other driver model
> * subsystems it was added to in device_add(), and removes it
> * from the kobject hierarchy.
> *
> * NOTE: this should be called manually _iff_ device_add() was
> * also called manually.
> */
>
> The rule here is to either use
> 1) device_register()/device_unregister()
> or
> 2) device_initialize()/device_add()/device_del()/put_device().
>
> So change PCI core to follow the rule and get rid of the redundant
> pci_dev_get()/pci_dev_put() pair.
>
> Signed-off-by: Jiang Liu <liuj97@...il.com>
> ---
> drivers/pci/probe.c | 1 -
> drivers/pci/remove.c | 4 ++--
> 2 files changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index 0840409..dacca26 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -1294,7 +1294,6 @@ void pci_device_add(struct pci_dev *dev, struct pci_bus *bus)
> {
> device_initialize(&dev->dev);
> dev->dev.release = pci_release_dev;
> - pci_dev_get(dev);
>
> dev->dev.dma_mask = &dev->dma_mask;
> dev->dev.dma_parms = &dev->dma_parms;
> diff --git a/drivers/pci/remove.c b/drivers/pci/remove.c
> index 04a4861..6c07bc5 100644
> --- a/drivers/pci/remove.c
> +++ b/drivers/pci/remove.c
> @@ -22,7 +22,7 @@ static void pci_stop_dev(struct pci_dev *dev)
> if (dev->is_added) {
> pci_proc_detach_device(dev);
> pci_remove_sysfs_dev_files(dev);
> - device_unregister(&dev->dev);
> + device_del(&dev->dev);
> dev->is_added = 0;
> }
>
> @@ -40,7 +40,7 @@ static void pci_destroy_dev(struct pci_dev *dev)
> up_write(&pci_bus_sem);
>
> pci_free_resources(dev);
> - pci_dev_put(dev);
> + put_device(&dev->dev);
> }
>
> /**
> --
> 1.7.1
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists