[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <503C9312.3070002@panasas.com>
Date: Tue, 28 Aug 2012 12:44:50 +0300
From: Boaz Harrosh <bharrosh@...asas.com>
To: Jan Kara <jack@...e.cz>
CC: "Eric W. Biederman" <ebiederm@...ssion.com>,
<linux-kernel@...r.kernel.org>, <netdev@...r.kernel.org>,
<linux-fsdevel@...r.kernel.org>,
"Serge E. Hallyn" <serge@...lyn.com>,
David Miller <davem@...emloft.net>,
Steven Whitehouse <swhiteho@...hat.com>,
Mark Fasheh <mfasheh@...e.com>,
Joel Becker <jlbec@...lplan.org>, Ben Myers <bpm@....com>,
Alex Elder <elder@...nel.org>,
Dmitry Monakhov <dmonakhov@...nvz.org>,
Abhijith Das <adas@...hat.com>
Subject: Re: [PATCH] userns: Add basic quota support v2
On 08/28/2012 12:05 PM, Jan Kara wrote:
>> +static inline u32 from_qown(struct user_namespace *user_ns, struct qown qown)
>> +{
>> + switch (qown.type) {
>> + case USRQUOTA:
>> + return from_kuid(user_ns, qown.uid);
>> + case GRPQUOTA:
>> + return from_kgid(user_ns, qown.gid);
>> + case XQM_PRJQUOTA:
>> + return (user_ns == &init_user_ns) ? qown.prj : -1;
>> + default:
>> + BUG();
>> + }
>> +}
> I would like a bit more if the function somehow expressed in its name
> that it returns id. id_from_qown() might be a bit too long given how often
> it is used. qown2id() would be OK but it would be inconsistent with how
> names of other functions you've added are formed. So I'm somewhat
> undecided...
>
qown_id()
> Honza
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists