lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 11 Sep 2012 09:27:24 +0800
From:	Alex Shi <>
To:	Peter Zijlstra <>
	Venkatesh Pallipadi <>,
	Suresh Siddha <>
Subject: Re: [PATCH 1/2] nohz: clean up select_nohz_load_balancer()

On 09/10/2012 11:26 PM, Peter Zijlstra wrote:

> On Mon, 2012-09-10 at 15:10 +0800, Alex Shi wrote:
>> There is no load_balancer to be selected now. It just set state of
>> nohz tick stopping.
>> So rename the function, pass the 'cpu' from parameter and then
>> remove the useless calling from tick_nohz_restart_sched_tick().
> Please check who wrote the code you're patching and attempt to CC them
> as well, in this case Venki and Suresh.

Thanks! will care about this from now on.

> I think the patch is fine, although I think we could have picked a
> better name, how about nohz_balance_enter_idle() ?

nohz_balance_enter_idle is good a name too. but I name it as
set_nohz_tick_stopped, since there is a clear_nohz_tick_stopped(), that
just do the opposed action of this function. According to this, is it
better to another function to nohz_balance_leave_idle()?
Or keep their current name?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists