[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20120912172554.GH19396@mwanda>
Date: Wed, 12 Sep 2012 20:25:54 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: Peter Senna Tschudin <peter.senna@...il.com>
Cc: Marcos Souza <marcos.souza.org@...il.com>,
Mauro Carvalho Chehab <mchehab@...radead.org>,
kernel-janitors@...r.kernel.org, linux-media@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 7/8] drivers/media/platform/davinci/vpbe.c: Removes
useless kfree()
On Wed, Sep 12, 2012 at 05:50:54PM +0200, Peter Senna Tschudin wrote:
> Marcos,
>
> > Now that you removed this kfree, you could remove this label too. Very
> > nice your cleanup :)
> Thanks!
>
> >
> >> vpbe_fail_sd_register:
> >> kfree(vpbe_dev->encoders);
> >> vpbe_fail_v4l2_device:
>
> The problem removing the label is that it will require some more work
> naming the labels. See:
> if (!vpbe_dev->amp) {
> ...
> goto vpbe_fail_amp_register;
>
> If I just remove the label vpbe_fail_amp_register, the label names
> will not make sense any more as the next label is
> vpbe_fail_sd_register. So I will need to change the name to something
> different or rename all labels to out1, out2, out3 or err1, err2,
> err3, or ....
>
> Any suggestions?
Labal names should not be numbers because this is not GW-BASIC. The
label should reflect what happens on the next line. Labeling the
place after the goto location where you started from is always
nonsense.
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists