[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1348133405.13371.30.camel@smile>
Date: Thu, 20 Sep 2012 12:30:05 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: viresh kumar <viresh.kumar@...aro.org>
Cc: Vinod Koul <vinod.koul@...el.com>, spear-devel@...t.st.com,
linux-kernel@...r.kernel.org, Hein Tibosch <hein_tibosch@...oo.es>
Subject: Re: [PATCH 2/7] dw_dmac: fill optional encoded parameters in
register structure
On Tue, 2012-09-18 at 13:29 +0530, viresh kumar wrote:
> On Tue, Sep 18, 2012 at 12:25 PM, Andy Shevchenko
> <andriy.shevchenko@...ux.intel.com> wrote:
> >> > +#define dma_raw_readl(addr, name) \
> >> > + readl((addr) + offsetof(struct dw_dma_regs, name))
> >> > +
> >> > +#define dma_raw_writel(addr, name, val) \
> >> > + writel((val), (addr) + offsetof(struct dw_dma_regs, name))
> >> > +
> >>
> >> But why don't you use earlier defined readl/writel macros:
> >> dma_readl and dma_writel?
>
> > If you look at further patches, namely 3rd, the access to the register
> > is needed before we allocate memory for the dw_dma structure.
>
> Ok. If i am not wrong, such calls are only required once for below line:
Actually twice...
> dw_params = dma_raw_readl(regs, DW_PARAMS
...here and for channel parameters.
> dma_raw_writel() is not used and shouldn't be required in future too.
> So remove it.
Ok
> dma_raw_readl() is required but the name is a bit confusing... this
> raw type is different
> from raw_readl...
>
> Can we name it dma_read_byaddr()?
> to make it more explicit.
Ok.
--
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Intel Finland Oy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists