[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20120925112236.GD28902@infradead.org>
Date: Tue, 25 Sep 2012 08:22:36 -0300
From: Arnaldo Carvalho de Melo <acme@...hat.com>
To: Feng Tang <feng.tang@...el.com>
Cc: Namhyung Kim <namhyung@...nel.org>, mingo@...e.hu,
a.p.zijlstra@...llo.nl, andi@...stfloor.org, dsahern@...il.com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 7/9] perf header: Add check_perf_magic() func
Em Tue, Sep 25, 2012 at 04:21:40PM +0800, Feng Tang escreveu:
> On Tue, 25 Sep 2012 11:07:15 +0900
> Namhyung Kim <namhyung@...nel.org> wrote:
>
> > On Mon, 24 Sep 2012 23:24:09 +0800, Feng Tang wrote:
> > [snip]
> > > +/* Return 0 if matched */
> > > +int check_perf_magic(u64 magic)
> > > +{
> > > + if (!memcmp(&magic, __perf_magic1, sizeof(magic))
> > > + || magic == __perf_magic2
> > > + || magic == __perf_magic2_sw)
> > > + return 0;
> > > +
> > > + return -1;
> > > +}
> >
> > Just an idea. How about returning version number instead of 0 so that
> > it can be used elsewhere those check is needed and possibly wants to
> > know the version number also?
> Sounds ok to me, I can add that if nobody has objection.
Leave it for when we need it?
What we need now is to see if a file is a perf.data file, so I think the
function is good as is.
Minor nitpicks: use bool, rename it to is_perf_magic(), no need for that
comment then, it becomes obvious from the function name :-)
- Arnaldo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists