[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20121002181001.GB3283@redhat.com>
Date: Tue, 2 Oct 2012 14:10:01 -0400
From: Vivek Goyal <vgoyal@...hat.com>
To: Kent Overstreet <koverstreet@...gle.com>
Cc: linux-bcache@...r.kernel.org, linux-kernel@...r.kernel.org,
dm-devel@...hat.com, axboe@...nel.dk, linux-s390@...r.kernel.org,
Chris Mason <chris.mason@...ionio.com>,
Jiri Kosina <jkosina@...e.cz>,
Heiko Carstens <heiko.carstens@...ibm.com>,
Martin Schwidefsky <schwidefsky@...ibm.com>,
Alasdair Kergon <agk@...hat.com>, tj@...nel.org,
Steven Whitehouse <swhiteho@...hat.com>,
Lars Ellenberg <drbd-dev@...ts.linbit.com>
Subject: Re: [dm-devel] [PATCH v3 06/26] block: Add bio_end_sector()
On Mon, Sep 24, 2012 at 03:34:46PM -0700, Kent Overstreet wrote:
[..]
> diff --git a/include/linux/bio.h b/include/linux/bio.h
> index 4e32be1..d985e90 100644
> --- a/include/linux/bio.h
> +++ b/include/linux/bio.h
> @@ -67,6 +67,7 @@
> #define bio_offset(bio) bio_iovec((bio))->bv_offset
> #define bio_segments(bio) ((bio)->bi_vcnt - (bio)->bi_idx)
> #define bio_sectors(bio) ((bio)->bi_size >> 9)
> +#define bio_end_sector(bio) ((bio)->bi_sector + bio_sectors(bio))
May be it is just me. But bio_end_sector() kind of sounds that it will
calculate to the last sector of bio. So I thought of it more as
bio_last_sector() and not the sector which is next to the last sector.
Will it make sense to introduce bio_last_sector() and use +1 everywhere.
Or may be we need a better name. Can't think of one though.
Thanks
Vivek
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists