[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.00.1210021251330.7383@chino.kir.corp.google.com>
Date: Tue, 2 Oct 2012 12:54:17 -0700 (PDT)
From: David Rientjes <rientjes@...gle.com>
To: Glauber Costa <glommer@...allels.com>
cc: Pekka Enberg <penberg@...nel.org>,
Christoph Lameter <cl@...ux.com>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
Andrew Morton <akpm@...ux-foundation.org>,
Pekka Enberg <penberg@...helsinki.fi>
Subject: Re: [PATCH v3] slab: Ignore internal flags in cache creation
On Tue, 2 Oct 2012, Glauber Costa wrote:
> diff --git a/mm/slab_common.c b/mm/slab_common.c
> index 9c21725..79be32e 100644
> --- a/mm/slab_common.c
> +++ b/mm/slab_common.c
> @@ -107,6 +107,13 @@ struct kmem_cache *kmem_cache_create(const char *name, size_t size, size_t align
> if (!kmem_cache_sanity_check(name, size) == 0)
> goto out_locked;
>
> + /*
> + * Some allocators will constraint the set of valid flags to a subset
> + * of all flags. We expect them to define CACHE_CREATE_MASK in this
s/CACHE_CREATE_MASK/SLAB_AVAILABLE_FLAGS/
I don't think SLAB_AVAILABLE_FLAGS is the best name we can come up with, I
think it should be at least something like CACHE_ALLOWED_FLAGS, but I'm
fine with whatever it turns out to be.
> + * case, and we'll just provide them with a sanitized version of the
> + * passed flags.
> + */
> + flags &= SLAB_AVAILABLE_FLAGS;
>
> s = __kmem_cache_alias(name, size, align, flags, ctor);
> if (s)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists