[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.02.1210071839040.2745@localhost6.localdomain6>
Date: Sun, 7 Oct 2012 18:44:14 +0200 (CEST)
From: Julia Lawall <julia.lawall@...6.fr>
To: walter harms <wharms@....de>
cc: Julia Lawall <Julia.Lawall@...6.fr>,
Antti Palosaari <crope@....fi>,
kernel-janitors@...r.kernel.org, rmallon@...il.com,
shubhrajyoti@...com, Mauro Carvalho Chehab <mchehab@...radead.org>,
linux-media@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 13/13] drivers/media/tuners/e4000.c: use macros for
i2c_msg initialization
On Sun, 7 Oct 2012, walter harms wrote:
>
>
> Am 07.10.2012 17:38, schrieb Julia Lawall:
>> From: Julia Lawall <Julia.Lawall@...6.fr>
>>
>> Introduce use of I2c_MSG_READ/WRITE/OP, for readability.
>>
>> In the second i2c_msg structure, a length expressed as an explicit constant
>> is also re-expressed as the size of the buffer, reg.
>>
>> A simplified version of the semantic patch that makes this change is as
>> follows: (http://coccinelle.lip6.fr/)
>>
>> // <smpl>
>> @@
>> expression a,b,c;
>> identifier x;
>> @@
>>
>> struct i2c_msg x =
>> - {.addr = a, .buf = b, .len = c, .flags = I2C_M_RD}
>> + I2C_MSG_READ(a,b,c)
>> ;
>>
>> @@
>> expression a,b,c;
>> identifier x;
>> @@
>>
>> struct i2c_msg x =
>> - {.addr = a, .buf = b, .len = c, .flags = 0}
>> + I2C_MSG_WRITE(a,b,c)
>> ;
>>
>> @@
>> expression a,b,c,d;
>> identifier x;
>> @@
>>
>> struct i2c_msg x =
>> - {.addr = a, .buf = b, .len = c, .flags = d}
>> + I2C_MSG_OP(a,b,c,d)
>> ;
>> // </smpl>
>>
>> Signed-off-by: Julia Lawall <Julia.Lawall@...6.fr>
>>
>> ---
>> drivers/media/tuners/e4000.c | 20 +++-----------------
>> 1 file changed, 3 insertions(+), 17 deletions(-)
>>
>> diff --git a/drivers/media/tuners/e4000.c b/drivers/media/tuners/e4000.c
>> index 1b33ed3..8f182fc 100644
>> --- a/drivers/media/tuners/e4000.c
>> +++ b/drivers/media/tuners/e4000.c
>> @@ -26,12 +26,7 @@ static int e4000_wr_regs(struct e4000_priv *priv, u8 reg, u8 *val, int len)
>> int ret;
>> u8 buf[1 + len];
>> struct i2c_msg msg[1] = {
>> - {
>> - .addr = priv->cfg->i2c_addr,
>> - .flags = 0,
>> - .len = sizeof(buf),
>> - .buf = buf,
>> - }
>> + I2C_MSG_WRITE(priv->cfg->i2c_addr, buf, sizeof(buf))
>> };
>>
>
> Any reason why struct i2c_msg is an array ?
I assumed that it looked more harmonious with the other uses of
i2c_transfer, which takes as arguments an array and the number of
elements.
But there are some files that instead use i2c_transfer(priv->i2c, &msg, 1).
I can change them all to do that if that is preferred. But maybe I
will wait a little bit to see if there are other issues to address at
the same time.
thanks,
julia
>
> re,
> wh
>
>> buf[0] = reg;
>> @@ -54,17 +49,8 @@ static int e4000_rd_regs(struct e4000_priv *priv, u8 reg, u8 *val, int len)
>> int ret;
>> u8 buf[len];
>> struct i2c_msg msg[2] = {
>> - {
>> - .addr = priv->cfg->i2c_addr,
>> - .flags = 0,
>> - .len = 1,
>> - .buf = ®,
>> - }, {
>> - .addr = priv->cfg->i2c_addr,
>> - .flags = I2C_M_RD,
>> - .len = sizeof(buf),
>> - .buf = buf,
>> - }
>> + I2C_MSG_WRITE(priv->cfg->i2c_addr, ®, sizeof(reg)),
>> + I2C_MSG_READ(priv->cfg->i2c_addr, buf, sizeof(buf))
>> };
>>
>> ret = i2c_transfer(priv->i2c, msg, 2);
>>
>> --
>> To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
>> the body of a message to majordomo@...r.kernel.org
>> More majordomo info at http://vger.kernel.org/majordomo-info.html
>>
>>
> --
> To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists