[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5071FA5D.30003@gmail.com>
Date: Mon, 08 Oct 2012 08:55:41 +1100
From: Ryan Mallon <rmallon@...il.com>
To: Julia Lawall <Julia.Lawall@...6.fr>
CC: Antti Palosaari <crope@....fi>, kernel-janitors@...r.kernel.org,
shubhrajyoti@...com, Mauro Carvalho Chehab <mchehab@...radead.org>,
linux-media@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/13] drivers/media/tuners/qt1010.c: use macros for i2c_msg
initialization
On 08/10/12 02:38, Julia Lawall wrote:
> From: Julia Lawall <Julia.Lawall@...6.fr>
>
> Introduce use of I2c_MSG_READ/WRITE/OP, for readability.
>
> A length expressed as an explicit constant is also re-expressed as the size
> of the buffer, when this is possible.
>
> A simplified version of the semantic patch that makes this change is as
> follows: (http://coccinelle.lip6.fr/)
>
> // <smpl>
> @@
> expression a,b,c;
> identifier x;
> @@
>
> struct i2c_msg x =
> - {.addr = a, .buf = b, .len = c, .flags = I2C_M_RD}
> + I2C_MSG_READ(a,b,c)
> ;
>
> @@
> expression a,b,c;
> identifier x;
> @@
>
> struct i2c_msg x =
> - {.addr = a, .buf = b, .len = c, .flags = 0}
> + I2C_MSG_WRITE(a,b,c)
> ;
>
> @@
> expression a,b,c,d;
> identifier x;
> @@
>
> struct i2c_msg x =
> - {.addr = a, .buf = b, .len = c, .flags = d}
> + I2C_MSG_OP(a,b,c,d)
> ;
> // </smpl>
>
> Signed-off-by: Julia Lawall <Julia.Lawall@...6.fr>
>
> ---
> drivers/media/tuners/qt1010.c | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/media/tuners/qt1010.c b/drivers/media/tuners/qt1010.c
> index bc419f8..37ff254 100644
> --- a/drivers/media/tuners/qt1010.c
> +++ b/drivers/media/tuners/qt1010.c
> @@ -25,10 +25,8 @@
> static int qt1010_readreg(struct qt1010_priv *priv, u8 reg, u8 *val)
> {
> struct i2c_msg msg[2] = {
> - { .addr = priv->cfg->i2c_address,
> - .flags = 0, .buf = ®, .len = 1 },
> - { .addr = priv->cfg->i2c_address,
> - .flags = I2C_M_RD, .buf = val, .len = 1 },
> + I2C_MSG_WRITE(priv->cfg->i2c_address, ®, sizeof(reg)),
> + I2C_MSG_READ(priv->cfg->i2c_address, val, 1),
This is a bit inconsistent. For single length values we should either
consistently use sizeof(val) or 1. This has both.
~Ryan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists