lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 16 Oct 2012 14:48:07 +0300
From:	Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:	Andrew Morton <akpm@...ux-foundation.org>,
	linux-kernel@...r.kernel.org, Joe Perches <joe@...ches.com>
Cc:	Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Subject: [PATCHv3 0/6] lib/string: introduce kbasename helper

There are several places in kernel that duplicate code to get last part of the
pathname. This patchset introduces a helper and few fixes.

Since v2:
- fixed Cc list in the patch 6/6 ("trace: ...")
- update patch 3/6 ("rts_pstor: ...") to not hide const qualifier
- send patch 1/1 to all people involved to the series
- rebase against recent linux-next
Since v1:
- fix changelog of the patch 1 - we are doing basename(3) alike helper
- usb related patch temporary excluded from series (under discussion with Greg)

Andy Shevchenko (6):
  lib/string: introduce helper to get base file name from given path
  lib: dynamic_debug: reuse kbasename()
  staging: rts_pstor: reuse kbasename()
  mm: reuse kbasename() functionality
  procfs: reuse kbasename() functionality
  trace: reuse kbasename() functionality

 drivers/staging/rts_pstor/trace.h |   24 ++++--------------------
 fs/proc/proc_devtree.c            |    7 ++-----
 include/linux/string.h            |   11 +++++++++++
 kernel/trace/trace_uprobe.c       |    8 ++++----
 lib/dynamic_debug.c               |    9 +--------
 mm/memory.c                       |    8 +++-----
 6 files changed, 25 insertions(+), 42 deletions(-)

-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists