[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAMuHMdXcQjDyen+o5aH=1zUOkNX-cfT3aXBOgCpyop=V67jk7w@mail.gmail.com>
Date: Wed, 17 Oct 2012 21:16:10 +0200
From: Geert Uytterhoeven <geert@...ux-m68k.org>
To: Will Deacon <will.deacon@....com>
Cc: linux-kernel@...r.kernel.org, linux-arch@...r.kernel.org,
Mike Frysinger <vapier@...too.org>,
Ben Herrenschmidt <benh@...nel.crashing.org>
Subject: Re: [RESEND PATCH 2/4] asm-generic: io: don't perform swab during
{in,out} string functions
On Wed, Oct 17, 2012 at 5:45 PM, Will Deacon <will.deacon@....com> wrote:
> The {in,out}s{b,w,l} functions are designed to operate on a stream of
> bytes and therefore should not perform any byte-swapping, regardless of
> the CPU byte order.
Euh?
They transfer a stream of bytes between memory and PCI/ISA I/O space by
reading from/writing to a single I/O port of width 8, 16, or 32 bits.
On big endian machines, I/O port accesses may need to be swapped.
> This patch fixes the generic IO header so that {in,out}s{b,w,l} call
> the __raw_{read,write} functions directly rather than going via the
> endian-correcting accessors.
Furthermore __raw_*() has different semantics besides endianness, like
ordering barriers. So you can't just change one for the other.
> Cc: Mike Frysinger <vapier@...too.org>
> Cc: Ben Herrenschmidt <benh@...nel.crashing.org>
> Acked-by: Arnd Bergmann <arnd@...db.de>
> Signed-off-by: Will Deacon <will.deacon@....com>
> ---
> include/asm-generic/io.h | 12 ++++++------
> 1 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/include/asm-generic/io.h b/include/asm-generic/io.h
> index 3607921..403b861 100644
> --- a/include/asm-generic/io.h
> +++ b/include/asm-generic/io.h
> @@ -148,7 +148,7 @@ static inline void insb(unsigned long addr, void *buffer, int count)
The "addr" parameter is actually a misnomer. Probably it should be "port".
Oops, inb() and friends also use "addr".
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists