[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20121022153012.253a6954.akpm@linux-foundation.org>
Date: Mon, 22 Oct 2012 15:30:12 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: "Kim, Milo" <Milo.Kim@...com>
Cc: Thierry Reding <thierry.reding@...onic-design.de>,
Richard Purdie <rpurdie@...ys.net>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] lp855x_bl: use generic PWM functions
On Fri, 19 Oct 2012 08:45:14 +0000
"Kim, Milo" <Milo.Kim@...com> wrote:
> > Generally this looks good. Obviously you'll need to update any users of
> > this driver as well. It might make sense to include those changes in
> > this patch to avoid interim build failures.
>
> Thanks for your review.
> So far no usages for this driver in the mainline.
> I've tested it in my own development environment instead.
>
> > Other than that I have just one smaller comment below.
> >
> > > + pwm_config(lp->pwm, duty, period);
> > > + duty == 0 ? pwm_disable(lp->pwm) : pwm_enable(lp->pwm);
> >
> > This is really ugly and should be written explicitly:
> >
> > if (duty == 0)
> > pwm_disable(lp->pwm);
> > else
> > pwm_enable(lp->pwm);
>
> Oh, I prefer using '?' to if-sentence because it looks clear to me.
> But if it's difficult to read/understand, I'll fix it.
> I'd like to have others' opinion.
>
Hey, it's better than
(*(duty ? pwm_enable : pwm_disable))(lp->pwm);
!
But yes, the original code is unusual and I think most kernel people
would have to stare at it for a bit longer than necessary to see
exactly what it's doing.
--- a/drivers/video/backlight/lp855x_bl.c~drivers-video-backlight-lp855x_blc-use-generic-pwm-functions-fix
+++ a/drivers/video/backlight/lp855x_bl.c
@@ -139,7 +139,10 @@ static void lp855x_pwm_ctrl(struct lp855
}
pwm_config(lp->pwm, duty, period);
- duty == 0 ? pwm_disable(lp->pwm) : pwm_enable(lp->pwm);
+ if (duty)
+ pwm_enable(lp->pwm);
+ else
+ pwm_disable(lp->pwm);
}
static int lp855x_bl_update_status(struct backlight_device *bl)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists