[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <508DA6DC.4070601@gmail.com>
Date: Sun, 28 Oct 2012 22:42:52 +0100
From: Sebastian Hesselbarth <sebastian.hesselbarth@...il.com>
To: Gregory CLEMENT <gregory.clement@...e-electrons.com>
CC: Mike Turquette <mturquette@...aro.org>,
Jason Cooper <jason@...edaemon.net>,
Andrew Lunn <andrew@...n.ch>,
linux-arm-kernel@...ts.infradead.org,
Arnd Bergmann <arnd@...db.de>, Olof Johansson <olof@...om.net>,
Ben Dooks <ben-linux@...ff.org>,
Ian Molton <ian.molton@...ethink.co.uk>,
Nicolas Pitre <nico@...xnic.net>,
Lior Amsalem <alior@...vell.com>,
Maen Suleiman <maen@...vell.com>,
Tawfik Bayouk <tawfik@...vell.com>,
Shadi Ammouri <shadi@...vell.com>,
Eran Ben-Avi <benavi@...vell.com>,
Yehuda Yitschak <yehuday@...vell.com>,
Nadav Haklai <nadavh@...vell.com>, Li Li <li.li@...onical.com>,
Ike Pan <ike.pan@...onical.com>,
Jani Monoses <jani.monoses@...onical.com>,
Chris Van Hoof <vanhoof@...onical.com>,
Dan Frazier <dann.frazier@...onical.com>,
Thomas Petazzoni <thomas.petazzoni@...e-electrons.com>,
Leif Lindholm <leif.lindholm@....com>,
Jon Masters <jcm@...hat.com>,
David Marlin <dmarlin@...hat.com>,
devicetree-discuss@...ts.ozlabs.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH V3 1/3] clk: mvebu: add armada-370-xp specific clocks
On 10/15/2012 02:18 PM, Gregory CLEMENT wrote:
> Add Armada 370/XP specific clocks: core clocks and CPU clocks.
>
> The CPU clocks are only for Armada XP for the SMP mode.
>
> ...
> +static struct core_clk_fn armada_370_clk_fn = {
> + .get_tclk_freq = armada_370_get_tclk_freq,
> + .get_pck_freq = armada_370_get_pck_freq,
> + .get_fab_freq_opt = armada_370_get_fab_freq_opt,
> +};
> +
> +static struct core_clk_fn armada_xp_clk_fn = {
> + .get_tclk_freq = armada_xp_get_tclk_freq,
> + .get_pck_freq = armada_xp_get_pck_freq,
> + .get_fab_freq_opt = armada_xp_get_fab_freq_opt,
> +};
> +
> +static const __initconst struct of_device_id clk_match[] = {
> + {
> + .compatible = "marvell,armada-370-core-clockctrl",
> + .data =&armada_370_clk_fn,
> + },
> +
> + {
> + .compatible = "marvell,armada-xp-core-clockctrl",
> + .data =&armada_xp_clk_fn,
> + },
> + {
> + /* sentinel */
> + }
> +};
Gregory,
armada_370_clk_fn and armada_xp_clk_fn cause section mismatches
as they are referenced within __initconst.
You should either rename them to armada_xp_clk_ops or annotate them
with the appropriate attribute.
Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists