lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Sun,  4 Nov 2012 00:43:31 +0900
From:	Akinobu Mita <akinobu.mita@...il.com>
To:	linux-kernel@...r.kernel.org, akpm@...ux-foundation.org
Cc:	Akinobu Mita <akinobu.mita@...il.com>,
	"Theodore Ts'o" <tytso@....edu>,
	Artem Bityutskiy <dedekind1@...il.com>,
	Adrian Hunter <adrian.hunter@...el.com>,
	David Woodhouse <dwmw2@...radead.org>,
	linux-mtd@...ts.infradead.org,
	Eilon Greenstein <eilong@...adcom.com>, netdev@...r.kernel.org,
	Robert Love <robert.w.love@...el.com>, devel@...n-fcoe.org,
	Michel Lespinasse <walken@...gle.com>
Subject: [PATCH v2 00/11] introduce random32_get_bytes() and random32_get_bytes_state()

This patchset introduces new functions into random32 library for
getting the requested number of pseudo-random bytes.

Before introducing these new functions into random32 library,
prandom32() and prandom32_seed() with "prandom32" prefix are
renamed to random32_state() and srandom32_state() respectively.

The purpose of this renaming is to prevent some kernel developers
from assuming that prandom32() and random32() might imply that only
prandom32() was the one using a pseudo-random number generator by
prandom32's "p", and the result may be a very embarassing security
exposure.

Changelog

* v2
- rename prandom32 to random32_state
- dropped lib/uuid.c patch
- add bnx2 and mtd_stresstest patches

Akinobu Mita (11):
  random32: rename prandom32 to random32_state
  random32: introduce random32_get_bytes() and
    random32_get_bytes_state()
  bnx2x: use random32_get_bytes()
  mtd: nandsim: use random32_get_bytes
  ubifs: use random32_get_bytes
  mtd: mtd_nandecctest: use random32_get_bytes instead of
    get_random_bytes()
  mtd: mtd_oobtest: convert to use random32_get_bytes_state()
  mtd: mtd_pagetest: convert to use random32_get_bytes_state()
  mtd: mtd_speedtest: use random32_get_bytes
  mtd: mtd_subpagetest: convert to use random32_get_bytes_state()
  mtd: mtd_stresstest: use random32_get_bytes()

 drivers/mtd/nand/nandsim.c                      |  5 +--
 drivers/mtd/tests/mtd_nandecctest.c             |  2 +-
 drivers/mtd/tests/mtd_oobtest.c                 | 49 +++++++-------------
 drivers/mtd/tests/mtd_pagetest.c                | 43 ++++++------------
 drivers/mtd/tests/mtd_speedtest.c               |  9 +---
 drivers/mtd/tests/mtd_stresstest.c              |  3 +-
 drivers/mtd/tests/mtd_subpagetest.c             | 42 +++++------------
 drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c |  5 +--
 drivers/scsi/fcoe/fcoe_ctlr.c                   |  4 +-
 fs/ubifs/debug.c                                |  8 ++--
 include/linux/random.h                          |  8 ++--
 lib/interval_tree_test_main.c                   |  7 +--
 lib/random32.c                                  | 60 ++++++++++++++++++++-----
 lib/rbtree_test.c                               |  6 +--
 14 files changed, 112 insertions(+), 139 deletions(-)

Cc: "Theodore Ts'o" <tytso@....edu>
Cc: Artem Bityutskiy <dedekind1@...il.com>
Cc: Adrian Hunter <adrian.hunter@...el.com>
Cc: David Woodhouse <dwmw2@...radead.org>
Cc: linux-mtd@...ts.infradead.org
Cc: Eilon Greenstein <eilong@...adcom.com>
Cc: netdev@...r.kernel.org
Cc: Robert Love <robert.w.love@...el.com>
Cc: devel@...n-fcoe.org
Cc: Michel Lespinasse <walken@...gle.com>

-- 
1.7.11.7

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists