[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1352475395-11917-1-git-send-email-elezegarcia@gmail.com>
Date: Fri, 9 Nov 2012 12:36:35 -0300
From: Ezequiel Garcia <elezegarcia@...il.com>
To: <linux-mtd@...ts.infradead.org>
Cc: <linux-kernel@...r.kernel.org>,
Ezequiel Garcia <elezegarcia@...il.com>,
David Woodhouse <dwmw2@...radead.org>
Subject: [PATCH] mtd_blkdev: Use a different name for block_device_operations variable
struct mtd_blktrans_ops is a type, and mtd_blktrans_ops is a variable.
To improve code clarity it's better to not use the same names,
so we just change the latter.
Cc: David Woodhouse <dwmw2@...radead.org>
Signed-off-by: Ezequiel Garcia <elezegarcia@...il.com>
---
drivers/mtd/mtd_blkdevs.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/mtd/mtd_blkdevs.c b/drivers/mtd/mtd_blkdevs.c
index f1f0671..26ef2a7 100644
--- a/drivers/mtd/mtd_blkdevs.c
+++ b/drivers/mtd/mtd_blkdevs.c
@@ -325,7 +325,7 @@ unlock:
return ret;
}
-static const struct block_device_operations mtd_blktrans_ops = {
+static const struct block_device_operations mtd_block_ops = {
.owner = THIS_MODULE,
.open = blktrans_open,
.release = blktrans_release,
@@ -401,7 +401,7 @@ int add_mtd_blktrans_dev(struct mtd_blktrans_dev *new)
gd->private_data = new;
gd->major = tr->major;
gd->first_minor = (new->devnum) << tr->part_bits;
- gd->fops = &mtd_blktrans_ops;
+ gd->fops = &mtd_block_ops;
if (tr->part_bits)
if (new->devnum < 26)
--
1.7.8.6
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists