lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 29 Nov 2012 15:29:15 -0800 (PST)
From:	Hugh Dickins <hughd@...gle.com>
To:	Andrew Morton <akpm@...ux-foundation.org>
cc:	Theodore Ts'o <tytso@....edu>, Zheng Liu <wenqing.lz@...bao.com>,
	Jeff liu <jeff.liu@...cle.com>,
	Jim Meyering <jim@...ering.net>,
	Paul Eggert <eggert@...ucla.edu>,
	Christoph Hellwig <hch@...radead.org>,
	Josef Bacik <josef@...hat.com>,
	Andi Kleen <andi@...stfloor.org>,
	Andreas Dilger <adilger@...ger.ca>,
	Dave Chinner <david@...morbit.com>,
	Marco Stornelli <marco.stornelli@...il.com>,
	Chris Mason <chris.mason@...ionio.com>,
	Sunil Mushran <sunil.mushran@...cle.com>,
	linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org,
	linux-mm@...ck.org
Subject: Re: [PATCH] tmpfs: support SEEK_DATA and SEEK_HOLE (reprise)

On Thu, 29 Nov 2012, Andrew Morton wrote:
> On Wed, 28 Nov 2012 17:22:03 -0800 (PST)
> Hugh Dickins <hughd@...gle.com> wrote:
> 
> > +/*
> > + * llseek SEEK_DATA or SEEK_HOLE through the radix_tree.
> > + */
> > +static pgoff_t shmem_seek_hole_data(struct address_space *mapping,
> > +				    pgoff_t index, pgoff_t end, int origin)
> 
> So I was starting at this wondering what on earth "origin" is and why
> it has the fishy-in-this-context type "int".
> 
> There is a pretty well established convention that the lseek seek mode
> is called "whence".
> 
> The below gets most of it.  Too anal?

No, not too anal: I'm all in favour of "whence", which is indeed
the name of that lseek argument - since mediaeval times I believe.

It's good to have words like that in the kernel source: while you're
in the mood, please see if you can find good homes for "whither" and
"thrice" and "widdershins".

Thanks!
Hugh

> 
> 
> From: Andrew Morton <akpm@...ux-foundation.org>
> Subject: lseek: the "whence" argument is called "whence"
> 
> But the kernel decided to call it "origin" instead.  Fix most of the
> sites.
> 
> Signed-off-by: Andrew Morton <akpm@...ux-foundation.org>
> ---
> 
>  fs/bad_inode.c           |    2 -
>  fs/block_dev.c           |    4 +--
>  fs/btrfs/file.c          |   16 +++++++-------
>  fs/ceph/dir.c            |    4 +--
>  fs/ceph/file.c           |    6 ++---
>  fs/cifs/cifsfs.c         |    8 +++----
>  fs/configfs/dir.c        |    4 +--
>  fs/ext3/dir.c            |    6 ++---
>  fs/ext4/dir.c            |    6 ++---
>  fs/ext4/file.c           |   22 ++++++++++----------
>  fs/fuse/file.c           |    8 +++----
>  fs/gfs2/file.c           |   10 ++++-----
>  fs/libfs.c               |    4 +--
>  fs/nfs/dir.c             |    6 ++---
>  fs/nfs/file.c            |   10 ++++-----
>  fs/ocfs2/extent_map.c    |   12 +++++------
>  fs/ocfs2/file.c          |    6 ++---
>  fs/pstore/inode.c        |    6 ++---
>  fs/read_write.c          |   40 ++++++++++++++++++-------------------
>  fs/seq_file.c            |    4 +--
>  fs/ubifs/dir.c           |    4 +--
>  include/linux/fs.h       |   12 +++++------
>  include/linux/ftrace.h   |    4 +--
>  include/linux/syscalls.h |    4 +--
>  kernel/trace/ftrace.c    |    4 +--
>  mm/shmem.c               |   20 +++++++++---------
>  26 files changed, 116 insertions(+), 116 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ