[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20121221184311.2da34111@redhat.com>
Date: Fri, 21 Dec 2012 18:43:11 -0200
From: Mauro Carvalho Chehab <mchehab@...hat.com>
To: YAMANE Toshiaki <yamanetoshi@...il.com>
Cc: Greg Kroah-Hartman <greg@...ah.com>, linux-media@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] staging/media: Fix trailing statements should be on
next line in go7007/go7007-fw.c
Em Mon, 5 Nov 2012 20:39:33 +0900
YAMANE Toshiaki <yamanetoshi@...il.com> escreveu:
> fixed below checkpatch error.
> - ERROR: trailing statements should be on next line
>
> Signed-off-by: YAMANE Toshiaki <yamanetoshi@...il.com>
> ---
> drivers/staging/media/go7007/go7007-fw.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/media/go7007/go7007-fw.c b/drivers/staging/media/go7007/go7007-fw.c
> index f99c05b..cfce760 100644
> --- a/drivers/staging/media/go7007/go7007-fw.c
> +++ b/drivers/staging/media/go7007/go7007-fw.c
> @@ -725,7 +725,8 @@ static int vti_bitlen(struct go7007 *go)
> {
> unsigned int i, max_time_incr = go->sensor_framerate / go->fps_scale;
>
> - for (i = 31; (max_time_incr & ((1 << i) - 1)) == max_time_incr; --i);
> + for (i = 31; (max_time_incr & ((1 << i) - 1)) == max_time_incr; --i)
> + ;
Nah, this doesn't sound right to me. IMO, in this specific case,
checkpatch.pl did a bad job.
At least on my eyes, the first line is easier to read than the other
two ones.
> return i + 1;
> }
>
Regards,
Mauro
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists